[Settings] Set automatically menu doesn't hide perfectly when turn on airplane mode/sim lock

RESOLVED DUPLICATE of bug 869367

Status

RESOLVED DUPLICATE of bug 869367
6 years ago
6 years ago

People

(Reporter: leo.bugzilla.gaia, Assigned: iliu)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: [TD-45877])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 761305 [details]
screenshot

1. Title : Set automatically menu doesn't hide perfectly when turn on airplane mode/sim lock
2. Precondition : Network connected
3. Tester's Action :
 1) Settings - Turn on airplain mode or Turn on SIM PIN
 2) Settings - Date & Time - Observe Set automatically menu
 3) Rebooting - Settings - Date & Time - Observe Set automatically menu
4. Detailed Symptom : Only Set automatically string is hidden and white block is remaining.
5. Expected : Set automatically menu have to hide perfectly.
6. Reproducibility: Y
   - Frequency Rate : 100%
7.Gaia Master/v1-train : Only reproduced on v1-train 
8. Version Info
Mozilla build ID: 20130526070207
Gaia Revision : 4d10e1297b859cacc174c0a54af61a7678d7c32d
Gecko Revision : 52341e43539a0e8b9aa77a9128cc3871439b8aa6
(Reporter)

Updated

6 years ago
blocking-b2g: --- → leo+
(Assignee)

Updated

6 years ago
Assignee: nobody → iliu
Hi Leo,

I don't think the expected result is reasonable for me. Even if we don't support set Date&Time automatically in airplan mode/SIM lock, user should be able to set Date&Time manually. But I feel strange for the redundant space(the blank space of Set automatically). The useless layout should update dynamically. What do you think we could nominate Bug 869367 for improving user experience?
Flags: needinfo?(leo.bugzilla.gaia)

Comment 2

6 years ago
(In reply to Ian Liu [:ianliu] from comment #1)
> Hi Leo,
> 
> I don't think the expected result is reasonable for me. Even if we don't
> support set Date&Time automatically in airplan mode/SIM lock, user should be
> able to set Date&Time manually. But I feel strange for the redundant
> space(the blank space of Set automatically). The useless layout should
> update dynamically. What do you think we could nominate Bug 869367 for
> improving user experience?

It's duplicated with Bug 869367.
The patch had landed in latest v1-train.
Flags: needinfo?(leo.bugzilla.gaia)
Hi Hyuna,

Looks like that you agree with my suggestion. But I don't see the patch be landed in v1-train.
https://github.com/mozilla-b2g/gaia/blob/v1-train/apps/settings/style/settings.css#L449

We should nominate Bug 869367 to be leo+ for the uplifting procedure.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 869367
(Reporter)

Updated

6 years ago
Whiteboard: [TD-45877]
You need to log in before you can comment on or make changes to this bug.