Closed Bug 882083 Opened 8 years ago Closed 8 years ago

Aurora Android nightlies failing with "RuntimeError: File "yandex.xml" not found in... \n Failed to add locale tr!"

Categories

(Release Engineering :: General, defect)

ARM
Android
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emorley, Unassigned)

References

Details

Android X86 mozilla-aurora nightly on 2013-06-12 00:40:50 PDT for push 6f7c753b3abc

slave: bld-linux64-ix-022

https://tbpl.mozilla.org/php/getParsedLog.php?id=24049636&tree=Mozilla-Aurora

{
05:27:12     INFO -  \nGenerating: search-jar
05:27:12     INFO -  printf "tr.jar:" > .deps/generated_tr/tmp-search.jar.mn
05:27:12     INFO -  ln -fn .deps/generated_tr/tmp-search.jar.mn .
05:27:12     INFO -  printf " \n locale/tr/browser/searchplugins/google.xml (google.xml)  \n locale/tr/browser/searchplugins/yandex.xml (yandex.xml)  \n locale/tr/browser/searchplugins/twitter.xml (twitter.xml)  \n locale/tr/browser/searchplugins/wikipedia-tr.xml (wikipedia-tr.xml)" >>  .deps/generated_tr/tmp-search.jar.mn
05:27:12     INFO -  /builds/slave/m-aurora-and-x86-ntly-00000000/build/obj-firefox/_virtualenv/bin/python /builds/slave/m-aurora-and-x86-ntly-00000000/build/config/JarMaker.py \
05:27:12     INFO -             -j ../../dist/bin/chrome \
05:27:12     INFO -            -s /builds/slave/m-aurora-and-x86-ntly-00000000/build/mobile/locales/en-US/searchplugins \
05:27:12     INFO -            -s /builds/slave/m-aurora-and-x86-ntly-00000000/mozilla-aurora/tr/mobile/searchplugins \
05:27:12     INFO -            -t /builds/slave/m-aurora-and-x86-ntly-00000000/build -f flat  --relativesrcdir=mobile/locales --locale-mergedir=/builds/slave/m-aurora-and-x86-ntly-00000000/./build/obj-firefox/merged --l10n-base=/builds/slave/m-aurora-and-x86-ntly-00000000/./mozilla-aurora/tr .deps/generated_tr/tmp-search.jar.mn
05:27:12     INFO -  processing .deps/generated_tr/tmp-search.jar.mn
05:27:12    ERROR -  Traceback (most recent call last):
05:27:12     INFO -    File "/builds/slave/m-aurora-and-x86-ntly-00000000/build/config/JarMaker.py", line 484, in <module>
05:27:12     INFO -      main()
05:27:12     INFO -    File "/builds/slave/m-aurora-and-x86-ntly-00000000/build/config/JarMaker.py", line 481, in main
05:27:12     INFO -      jm.makeJar(infile, options.j)
05:27:12     INFO -    File "/builds/slave/m-aurora-and-x86-ntly-00000000/build/config/JarMaker.py", line 228, in makeJar
05:27:12     INFO -      self.processJarSection(m.group('jarfile'), lines, jardir)
05:27:12     INFO -    File "/builds/slave/m-aurora-and-x86-ntly-00000000/build/config/JarMaker.py", line 318, in processJarSection
05:27:12     INFO -      self._processEntryLine(m, outHelper, jf)
05:27:12     INFO -    File "/builds/slave/m-aurora-and-x86-ntly-00000000/build/config/JarMaker.py", line 349, in _processEntryLine
05:27:12     INFO -      .format(src, ', '.join(src_base)))
05:27:12     INFO -  RuntimeError: File "yandex.xml" not found in /builds/slave/m-aurora-and-x86-ntly-00000000/build/mobile/locales/en-US/searchplugins, /builds/slave/m-aurora-and-x86-ntly-00000000/mozilla-aurora/tr/mobile/searchplugins, /builds/slave/m-aurora-and-x86-ntly-00000000/build/obj-firefox/mobile/locales/.deps/generated_tr, /builds/slave/m-aurora-and-x86-ntly-00000000/build/obj-firefox/mobile/locales
05:27:12    ERROR -  make[2]: *** [searchplugins] Error 1
05:27:12     INFO -  make[2]: Leaving directory `/builds/slave/m-aurora-and-x86-ntly-00000000/build/obj-firefox/mobile/locales'
05:27:12    ERROR -  make[1]: *** [chrome-tr] Error 2
05:27:12     INFO -  make[1]: Leaving directory `/builds/slave/m-aurora-and-x86-ntly-00000000/build/obj-firefox/mobile/locales'
05:27:12     INFO -  make: *** [chrome-tr] Error 2
05:27:12    ERROR - Return code: 2
05:27:12    ERROR - Failed to add locale tr!
}

Presuming caused by bug 859381.
No longer blocks: 859381
Depends on: 859381
Bustaqe fix landed, retriggered.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.