App videos do not work in app details page

VERIFIED FIXED in 2013-08-01

Status

P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: julian.mozbugs, Assigned: basta)

Tracking

2013-08-01
x86_64
Windows 7
Points:
---

Details

(URL)

(Reporter)

Description

5 years ago
Steps to reproduce:
1. Load an app that has a video preview (ex. https://marketplace-dev.allizom.org/app/test-app-paidbimmer/ )
2. Click on the video thumbnail.

Expected results:
The video starts playing in the displayed window.

Actual results:
An attention icon is displayed. The video is not working.

Notes/Issues:
Verified on FF24 (Win 7).
Screencast for this issue http://screencast.com/t/WfRAdpnvptmY
(Assignee)

Comment 1

5 years ago
The CDN is responding with a one-byte 206 Partial Content response.

This sounds like an ops issue, yes?
Assignee: nobody → jthomas
Priority: -- → P2
Component: Consumer Pages → Server Operations: AMO Operations
Product: Marketplace → mozilla.org
QA Contact: oremj
Target Milestone: 2013-06-13 → ---
Version: 1.0 → other
What is the path to the video on this page?

Updated

5 years ago
Flags: needinfo?(mattbasta)
(Assignee)

Comment 3

5 years ago
https://marketplace-dev-cdn.allizom.org/img/uploads/previews/full/98/98993.webm?modified=1371040578

I'm not sure what kind of demon magic is going on, but when I hit the video directly, it makes three requests to the server.
Flags: needinfo?(mattbasta)
The nginx configuration for this domain looks okay and webm video plays correctly in browser when visiting the url directly. Are we setting the Range headers here correctly when requesting the video?

Comment 5

5 years ago
I don't think this is a server bug. The web console shows the video being loaded correctly. Does this work locally?
Component: Server Operations: AMO Operations → Consumer Pages
Product: mozilla.org → Marketplace
QA Contact: oremj
Version: other → 1.5

Updated

5 years ago
Assignee: jthomas → mattbasta
Target Milestone: --- → 2013-08-01
(Assignee)

Comment 6

5 years ago
https://github.com/mozilla/fireplace/commit/a85daaafbd5a2679eb1c1992b28659057c72dad2

Turns out the API changed at some point and we were looking at the "type" field instead of "filetype".
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: 2013-08-01 → ---
Target Milestone: --- → 2013-08-01
(Reporter)

Comment 7

5 years ago
Verified as fixed in https://marketplace-dev.allizom.org/ on FF25 (Win 7).
Postfix screencast http://screencast.com/t/YQkH7X42kK
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.