Context menu mixed-up when right-click image in ImageMap

VERIFIED DUPLICATE of bug 33583

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 33583
17 years ago
13 years ago

People

(Reporter: mdimitrio, Assigned: Paul Chen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.1+) Gecko/20010627
BuildID:    2001062704

If you right click the "CNET Computers.com" top image (cnet-1016-title-sm.gif),
you'll get a very strange context menu, giving you, for instance, "open link in
new window" even when you right-clicked a part that's not inside the image map,
you don't get the normal image options like "View image", "Block Images from
this Server", and etc.

Note: I've chosen "Browser-General" in component because it has to do with many
things linked, not only menu, or links, or images, or imagemaps, but all of them
together. Perhaps it's a problem in rendering Image Maps, IMHO.

Reproducible: Always

Marcos.

Comment 1

17 years ago
Confirming on build 2001062504 win32

This belongs in XPApps.

A fix for this bug, may or may not involve fixing bug 33583
Assignee: asa → pchen
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps
Ever confirmed: true
QA Contact: doronr → sairuh

Comment 2

17 years ago
the problem is well known and relatively well described in that bug.

Basically the context menu only finds out about the <area name=foo> which 
doesn't necessarily have a one-to-one correspondence w/ <img id=bar 
usemap=#foo><img id=baz usemap=#foo> ... if you have ideas about fixing it we'd 
be overjoyed.

*** This bug has been marked as a duplicate of 33583 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.