Closed Bug 882197 Opened 8 years ago Closed 8 years ago

[keyboard] no word suggestion appears after choosing the first word suggestion

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:leo+, b2g18 verified, b2g-v1.1hd fixed)

RESOLVED FIXED
blocking-b2g leo+
Tracking Status
b2g18 --- verified
b2g-v1.1hd --- fixed

People

(Reporter: tchung, Assigned: djf)

Details

(Keywords: regression)

Attachments

(1 file)

word suggestions stops displaying words after you select the first word found.  follow STR below.

Repro:
1) install leo 1.1 nightly build:
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/b4f8f0a288ca
Gaia   ba1cf2af3f0286dc665492e2ed19275c8aa34a34
BuildID 20130611230208
Version 18.0

2) enable word suggestion in settings
3) type in something and check the word suggestion list (ie: "hel" , and see a list below.
4) choose the highlighted word ("Hello")
5) now start typing a second word
6) Verify the word suggestion bar is blank and nothing is returned.
** Note: if you dont select a word in step 4, and keep typing, word suggestion continues to work, up until you select something.

Expected:
- word suggestion always displays selections per words

Actual:
- word suggestions stop displaying words after selecting one from the list.
fwiw, i used the SMS App above to test this.
Pressing backspace to undo a Word Suggestion selection also stops functioning after selecting the first Word Suggestion.
The Polish, German, Portuguese, French, and Spanish Language settings are affected by this bug. Once Word Correction stops working it will begin working again if the Application is closed and then reopened (test in Messages App). 

Checked on 1.1 v1train Unagi build
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev64f8f0a288ca
Gaia: 847db47241459b5944ba40bacc94b15977d8a02e
Build ID: 20130612070210
Version 18.0
Assignee: nobody → dflanagan
This bug was caused by a hurried patch in bug 878843. The same patch also caused bug 882327. These were not visible on v1-train until bug 861515 was uplifted, however, so it was not caught sooner.  The bug exists on master as well, but isn't manifesting because for some reason the activate() method is being called every time we do an auto-correction and that is resetting the cursor.
Attachment #761730 - Flags: review?(dhylands)
This patch also fixes bug 882327
Attachment #761730 - Flags: review?(dhylands) → review+
Comment on attachment 761730 [details]
link to patch on github

[Approval Request Comment]
Bug caused by (feature/regressing bug #): this regression was caused by faulty code in the patch for bug 878843 that was not triggered until bug 861515 was uplifted to b2g18.
User impact if declined: auto-correction and word suggestions will be badly broken.
Testing completed: 
Risk to taking this patch (and alternatives if risky): almost none: its a trivial 2 line patch.
String or UUID changes made by this patch:
Attachment #761730 - Flags: approval-mozilla-b2g18?
Fixed on master: https://github.com/mozilla-b2g/gaia/commit/d86821224617d03f566fa7668e5fe68df764893e
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
blocking-b2g: leo? → leo+
v1.1hd: 1ed99fe8c212530ff4bce91aab9790637f505d22
Attachment #761730 - Flags: approval-mozilla-b2g18?
This issue does not Repro anymore. Word suggestions are being displayed as per the user's selection on the keyboard.

Environmental Variables
Build ID: 20130717070237
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/582e3a7018b0
Gaia: c506c50adaaebcf729ac3c27887ba2931ab79040
Platform Version: 18.1
Tested for Leo device with Build ID: 20130717070237
You need to log in before you can comment on or make changes to this bug.