[Mac] Lightning 2.5, 2.6 & 2.7 not working [TypeError: Components.classes[cid] is undefined]

RESOLVED FIXED in 2.5

Status

Calendar
General
--
blocker
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Paenglab, Assigned: Fallen)

Tracking

({regression})

Lightning 2.5
x86
Mac OS X
regression

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
In console I get:

Tue May 28 2013 23:07:31
Error: TypeError: Components.classes[cid] is undefined
Source file: resource://calendar/modules/calUtils.jsm -> file:///Users/richi/Library/Thunderbird/Profiles/vhf50963.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 16

and:

Tue May 28 2013 23:07:31
Error: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
Source file: resource://calendar/modules/calUtils.jsm -> file:///Users/richi/Library/Thunderbird/Profiles/vhf50963.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 92

Updated

4 years ago
Summary: Lightning 2.6a1 not working with Thunderbird 24.0a1 → [Mac] Lightning 2.6a1 not working with Thunderbird 24.0a1 [TypeError: Components.classes[cid] is undefined]

Comment 1

4 years ago
Most probably the registration of the binary component doesn't work correctly. Comparing win32 and macosx xpi I see:

> lightning-2.6a1.en-US.win32.xpi\components\libical.manifest
>     binary-component calbasecomps.dll

> lightning-2.6a1.en-US.mac.xpi\components\components.manifest
>     binary-component Darwin_x86-gcc3/libcalbasecomps.dylib ABI=Darwin_x86-gcc3
>     binary-component Darwin_x86_64-gcc3/libcalbasecomps.dylib ABI=Darwin_x86_64-gcc3
> lightning-2.6a1.en-US.mac.xpi\components\libical.manifest
>     binary-component libcalbasecomps.dylib

Should the platform specific information that is now in components\components.manifest in components\libical.manifest?
Version: unspecified → Lightning 2.6
(Assignee)

Comment 2

4 years ago
Indeed, it should be in libical.manifest. Likely this is a problem with the unify process done during the mac build.

Comment 3

4 years ago
Created attachment 762123 [details] [diff] [review]
put binary-component into libical.manifest

Patch is untested because I don't have access to Mac OS X. Please test if it fixes the problem.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #762123 - Flags: review?(philipp)
(Assignee)

Comment 4

4 years ago
Comment on attachment 762123 [details] [diff] [review]
put binary-component into libical.manifest

Review of attachment 762123 [details] [diff] [review]:
-----------------------------------------------------------------

Since this is the universal packaging and my mac isn't doing universal builds, its probably easier to just push this and see what the new builds say. It can't be more broken than it is now. Code looks good though. r=philipp
Attachment #762123 - Flags: review?(philipp) → review+

Comment 5

4 years ago
Pushed to https://hg.mozilla.org/comm-central/rev/788084ca950a
(Reporter)

Comment 6

4 years ago
Still the same errors in console. Lightning build ID: 20130614030626

Comment 7

4 years ago
Ok, in that case someone with access to Mac OS X should take over.

Richard, do you know if other versions like Lightning 2.5a2 or Lightning 2.4b1 are broken too?
Assignee: ssitter → nobody
Severity: normal → critical
Status: ASSIGNED → NEW
(Reporter)

Comment 8

4 years ago
I have only Daily installed and can't say if this versions are broken.

Comment 9

4 years ago
I can confirm that Lightning 2.5a2 for Thunderbird 23.0a2 (Earlybird) is broken too on Mac OS X !!!

Comment 10

4 years ago
Philipp, I suspect this might be problem regressed by the ical.js changes. Could you have a look before this problems hits comm-beta?
Summary: [Mac] Lightning 2.6a1 not working with Thunderbird 24.0a1 [TypeError: Components.classes[cid] is undefined] → [Mac] Lightning 2.5 & 2.6 not working [TypeError: Components.classes[cid] is undefined]
Version: Lightning 2.6 → Lightning 2.5
(Assignee)

Comment 11

4 years ago
Yes, I'll take a look at this some time this week.
Severity: critical → blocker
(Assignee)

Comment 12

4 years ago
Sorry for the delay, I really need to get to this - this week! :)

Comment 13

4 years ago
When traveling this week I switched from Linux to OSX and have not been able to use my calendar. The error I see in EarlyBird is:

Timestamp: 6/27/13 11:41:49 AM
Error: [Exception... "Component returned failure code: 0x80570018 (NS_ERROR_XPC_BAD_IID) [nsIJSCID.createInstance]"  nsresult: "0x80570018 (NS_ERROR_XPC_BAD_IID)"  location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///.../extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js :: _calIcalCreator/< :: line 16"  data: no]
Source File: resource://calendar/modules/calUtils.jsm -> file:///.../extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 16

Comment 14

4 years ago
Bob,
it is obvious that only me and, for now, you, are using Earlybird and/or Daily for OSX.
So relax and wait, as me, for a month or more. :)
Alexis

Updated

4 years ago
Summary: [Mac] Lightning 2.5 & 2.6 not working [TypeError: Components.classes[cid] is undefined] → [Mac] Lightning 2.5, 2.6 & 2.7 not working [TypeError: Components.classes[cid] is undefined]
(Assignee)

Comment 15

4 years ago
Created attachment 769632 [details] [diff] [review]
Fix - v1

This should take care. The interfaces line was missing from the merged file.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #769632 - Flags: review?(ssitter)

Comment 16

4 years ago
Comment on attachment 769632 [details] [diff] [review]
Fix - v1

Cannot test or verify if the patch works or not. Therefore trust you and blank r+
Attachment #769632 - Flags: review?(ssitter) → review+
(Assignee)

Comment 17

4 years ago
Pushed to comm-central changeset 089f43fe715b
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.7
(Assignee)

Comment 18

4 years ago
Will push to aurora/beta as soon as we have builds that work.
(Assignee)

Comment 19

4 years ago
Backported to releases/comm-aurora changeset 0f58049a758d
Target Milestone: 2.7 → 2.6
(Assignee)

Comment 20

4 years ago
Backported to releases/comm-beta changeset 7dfe4b899bca
Target Milestone: 2.6 → 2.5
You need to log in before you can comment on or make changes to this bug.