[MMS] Messages list. Date separator shows the wrong day

RESOLVED DUPLICATE of bug 885278

Status

Firefox OS
Gaia::SMS
RESOLVED DUPLICATE of bug 885278
5 years ago
4 years ago

People

(Reporter: vicky, Assigned: fcampo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: MMS_TEF [mozilla-triage])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 761915 [details]
shows before and after restarting the app

When opening the app, messages from yesterday are listed under the "TODAY" label. When restarting the app, the label changes to "TODAY". See attachment showing both screenshots with one minute time difference.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
Assignee: nobody → fbsc

Updated

5 years ago
Whiteboard: MMS_TEF
(Assignee)

Updated

5 years ago
Assignee: fbsc → fernando.campo

Comment 1

5 years ago
Is this a regression? If not, we recommend not blocking.
Whiteboard: MMS_TEF → MMS_TEF [mozilla-triage]
It is a regressions. Previously the header were updated automatically.
(Assignee)

Comment 3

5 years ago
Created attachment 763628 [details] [review]
Link to PR

Apparently the problem is not on the date headers (nor creation or updating) but on the FixedHeader, which keeps the old date and is shown over the real header.

I took the approach of updating the fixed header when the regular header is updated too.
Attachment #763628 - Flags: review?(fbsc)
I've been testing and also I've found more stuff related with localization. As we have a leo+ for tracking this Im gonna mark as DUP of 885278.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 885278

Updated

5 years ago
blocking-b2g: leo? → ---
Attachment #763628 - Flags: review?(fbsc)
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.