Download panel crash in some about-pages

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: alina.jafi, Unassigned)

Tracking

21 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130512193902

Steps to reproduce:

Some about-pages such as about:downloads, about:addons, about:preferences, about:permissions remove toolbar, so you can’t see download progress when they are active. 
First, in about:config change browser.tabs.onTop to false in order to have the toolbar in all about-pages. Then open one of the above about-pages and click on the download panel icon on the toolbar.


Actual results:

The download panel crashes and top toolbars are removed. Opening a new tab will return the toolbars, but the download panel remains crashed and shows nothing in that window.
After then opening one of the above about-pages in the same window will remove the toolbars. 
Download panel will work in a new window. 


Expected results:

The download panel should apear as always does.

Comment 1

6 years ago
(In reply to ali.najafi.88 from comment #1)
> The download panel crashes and top toolbars are removed. Opening a new tab
> will return the toolbars, but the download panel remains crashed and shows
> nothing in that window.

What exactly do you mean by "download panel crashes"? Can you add a screenshot? And, does this problem happen on a new profile and/or if you restart with add-ons disabled (there's an option to do this in the help menu)? Thanks!
Component: Untriaged → Downloads Panel
(Reporter)

Comment 2

6 years ago
Yes, I just wanted to mention the problem exists with (manually) disabling all add-ons, but not in safe mode (restart with add-ons disabled).

Comment 3

6 years ago
(In reply to ali.najafi.88 from comment #2)
> Yes, I just wanted to mention the problem exists with (manually) disabling
> all add-ons, but not in safe mode (restart with add-ons disabled).

It would still be nice to have a screenshot. Could you also check if you can see any errors in the error console? (There should be a menuitem under Tools; but it's possible you may need to open about:config and toggle the devtools.errorconsole.enabled pref so its value is 'true')
(Reporter)

Comment 4

6 years ago
Created attachment 761990 [details]
Download panel crash

Download button doesn’t work, but it shows remaining time as well as animations.
(Reporter)

Comment 5

6 years ago
Created attachment 761996 [details]
Error console

Error Console says:

Downloads button cannot be found
chrome://browser/content/downloads/downloads.js
(Reporter)

Comment 6

6 years ago
I’m using Firefox on Ubuntu, so just tried to reproduce the bug on Lubuntu and both Ubuntu live and guest user – it doesn’t occur.
I’ve had Download Panel Tweaks add-on, so installed it on other modes to see if it’s related to the bug – it’s not.
Seems it’s because of my personal settings. I may need to reset Firefox.
Ali, are you still experiencing this issue?
(Reporter)

Comment 8

5 years ago
No, after a Firefox reset I couldn’t reproduce the bug. I couldn’t find the reason as well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.