Closed Bug 882637 Opened 7 years ago Closed 7 years ago

crash in mozilla::nsDOMCameraControl::Result @ nsXPCWrappedJS::AddRef

Categories

(Firefox OS Graveyard :: General, defect, critical)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(firefox23 unaffected, firefox24 affected)

RESOLVED DUPLICATE of bug 882328
Tracking Status
firefox23 --- unaffected
firefox24 --- affected

People

(Reporter: scoobidiver, Unassigned)

References

Details

(Keywords: crash, regression, Whiteboard: [b2g-crash])

Crash Data

B2G 24.0a1 is also affected by that disease.

Frame 	Module 	Signature 	Source
0 	libxul.so 	nsXPCWrappedJS::AddRef 	XPCWrappedJS.cpp:158
1 	libxul.so 	nsXPTCStubBase::AddRef 	xptcall.cpp:30
2 	libxul.so 	mozilla::nsDOMCameraControl::Result 	nsCOMPtr.h:578
3 	libxul.so 	InitGonkCameraControl::Run 	GonkCameraControl.cpp:192
4 	libxul.so 	nsThread::ProcessNextEvent 	nsThread.cpp:626
5 	libmozglue.so 	free 	jemalloc.c:6597
6 	libxul.so 	moz_free 	mozalloc.cpp:48
7 	libxul.so 	NS_ProcessNextEvent 	nsThreadUtils.cpp:238
8 	libxul.so 	nsThread::ThreadFunc 	nsThread.cpp:264
9 	libnss3.so 	_pt_root 	ptthread.c:204
10 	libnss3.so 	PR_JoinThread 	ptthread.c:613
11 	libnss3.so 	PR_JoinThread 	ptthread.c:613
12 	libc.so 	__thread_entry 	pthread.c:217
13 	libc.so 	pthread_create 	pthread.c:357 

Reports at:
https://crash-stats.mozilla.com/report/list?product=B2G&signature=nsXPCWrappedJS%3A%3AAddRef%28%29
InitGonkCameraControl::mOnSuccessCb and mOnErrorCb should be nsMainThreadPtrHandle, which is what nsDOMCameraControl::Result and GetCameraResult::mOnSuccessCb and mOnErrorCb should be as well.
I seems dup of Bug 882328.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 882328
You need to log in before you can comment on or make changes to this bug.