Closed Bug 882642 Opened 6 years ago Closed 6 years ago

[MMS] Error: "part is null" {file: ".../MobileMessageDatabaseService.js" line: 780} causing SMS/MMS conversation to go permanently blank

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 890218

People

(Reporter: jaws, Unassigned)

References

Details

Attachments

(1 file)

I got an MMS on my phone, disconnected from WiFi and waited for the Edge icon to appear in the notification bar. I then clicked the button to download the MMS.

The attachment appeared to be downloading, but it never completed and the data usage stopped incrementing. I exited the SMS app by holding down Home and then killing the SMS app in the overlay that appears.

Now when I enter the conversation thread with that particular person, there are no text messages to display at all.

Running logcat I see the following error:

E/GeckoConsole(  536): [JavaScript Error: "part is null" {file: "jar:file:///system/b2g/omni.ja!/components/MobileMessageDatabaseService.js" line: 780}]

I am running build 20130611074722 on my Unagi phone (build 1.1.0 beta).
I should note that I got this error before upgrading to 20130611074722. I then saw the update and thought maybe it would fix it, but it didn't fix it.
Severity: normal → major
Summary: Error: "part is null" {file: ".../MobileMessageDatabaseService.js" line: 780} → Error: "part is null" {file: ".../MobileMessageDatabaseService.js" line: 780} causing SMS/MMS conversation to go permanently blank
Summary: Error: "part is null" {file: ".../MobileMessageDatabaseService.js" line: 780} causing SMS/MMS conversation to go permanently blank → [MMS] Error: "part is null" {file: ".../MobileMessageDatabaseService.js" line: 780} causing SMS/MMS conversation to go permanently blank
Will this be sufficient? It wouldn't hurt to do this check regardless.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #762790 - Flags: review?(gene.lian)
This error is also preventing me from deleting the message thread, so I'm unable to fix the thread of conversations with this contact.
Comment on attachment 762790 [details] [diff] [review]
Patch to paper around the issue

This fix looks really weird to me. If it can enter the loop then it definitely means both |part| and |parts| must have something. How could the |part| be null/undefined?

I'm really curious about the root cause of this bug. Could you please dump the |parts| and see what it is when this bug is happening? Thanks!
Attachment #762790 - Flags: review?(gene.lian)
(In reply to Gene Lian [:gene] from comment #4)
> Comment on attachment 762790 [details] [diff] [review]
> Patch to paper around the issue
> 
> This fix looks really weird to me. If it can enter the loop then it
> definitely means both |part| and |parts| must have something. How could the
> |part| be null/undefined?
> 
> I'm really curious about the root cause of this bug. Could you please dump
> the |parts| and see what it is when this bug is happening? Thanks!

Sorry, I had to reset my phone as it was quite unusable without this bug fixed.

I wasn't able to test that patch since I've just been using the distributed beta builds and I don't yet know how to push changes to my phone.
Chia-hung, can you take this?
Assignee: jaws → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(ctai)
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(ctai)
Resolution: --- → DUPLICATE
Duplicate of bug: 890218
Blocks: 897893
You need to log in before you can comment on or make changes to this bug.