Right-clicking link in message and choosing "Open Link in New Window" opens to Home

VERIFIED DUPLICATE of bug 85264

Status

VERIFIED DUPLICATE of bug 85264
18 years ago
14 years ago

People

(Reporter: jonrubin, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Found on 6.1b beta release build on Win98-en.

Steps:
1) Close all instances of Netscape.
2) Open Mail.
3) Go to a message that has a link in it and right-click on the link.
4) Choose "Open Link in New Window".  The browser opens to Home, not the
selected link.  Any subsequent attempt to right-click on the link and open in a
new window will work correctly.

Note: This only happens if Mail was opened while the browser was closed.  If you
open Mail, then open the browser and close it, the bug does not occur.  Also,
simply clicking on the link will not cause the bug to occur.  The steps have to
be followed precisely.

Comment 1

18 years ago
See also bug 89768.

Comment 2

18 years ago
Did the backout of 90288 and fix for 82720 cause this to be fixed as it did with
91531?
(Reporter)

Comment 3

18 years ago
Yes, I checked the 07-23-branch build, and this now works correctly on the branch.
(Reporter)

Comment 4

18 years ago
Actually, I don't know if it's a consequence of the backout and fix that selmer
mentioned, but I've noticed a change in functionality that's a minor issue, but
doesn't seem to be the correct functionality.  If I have all browser instances
closed and I then open a new window by right-clicking a link in a message, the
new window does open to the correct page.  However, if I then click another link
in a message (not right-click), a second browser window opens (to the correct
page).  Every subsequent click of a message link will appear in the second
window, not the original one that was opened through right-clicking.  I've also
noticed this behavior if I click Help>About Netscape 6 in Mail: If I click a
link in a message, it won't show up in the About window; it will cause a second
browser window to open.
(Reporter)

Comment 5

18 years ago
It seems that the windows opened via right-clicking and selecting "Open Link in
New Window" have an exclusive status such that clicking on links in messages the
normal way (not right-clicking) will cause the link to open in a separate
window.  For example, if I open a link by right-clicking "Open Link in New
Window",  then normal-click a second link, the second link will open a separate
window.  If I right-click a third link (Open Link in New Window), of course that
will cause a third browser window to open.  If I then regular-click another
message link, that link will open in the second window; both right-click spawned
windows remain unchanged.
(Reporter)

Comment 6

18 years ago
Ditto for Help>About.

Updated

18 years ago
QA Contact: esther → stephend

Comment 7

18 years ago
cc: mscott, jst.

Comment 8

18 years ago
Just talked to MScott, Jon Rubin's symptoms are dup of 85264.  This bug should
now be closed fixed or dup against 82720 or something.

*** This bug has been marked as a duplicate of 85264 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.