If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Bluetooth] Unknown devices in discovered Bluetooth devices

RESOLVED DUPLICATE of bug 880157

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 880157
4 years ago
4 years ago

People

(Reporter: tzimmermann, Assigned: tzimmermann)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

When discovering Bluetooth devices in the Settings app, sometimes devices are only listed as 'Unknown device'. The reason is that the bluetooth system or device does not supply us with a name for the device.

Visible devices broadcast their availability, and already discovered 'unknown' devices sometimes update their entry with a name. In this case we can update the device's entry in the Settings app from the new information.
Created attachment 762049 [details]
Pull request: https://github.com/mozilla-b2g/gaia/pull/10369

Tested with my Unagi + headset and PC.
Attachment #762049 - Flags: review?(ehung)
Comment on attachment 762049 [details]
Pull request: https://github.com/mozilla-b2g/gaia/pull/10369

Hi Thomas, thanks for the patch here, I never know that a duplicate found device will carry a name update. 
I think the patch is good but I'd like to pass the review to Arthur for a test and follow-up my only one question commented on Github. Thanks! :)
Attachment #762049 - Flags: review?(ehung) → review?(arthur.chen)
Comment on attachment 762049 [details]
Pull request: https://github.com/mozilla-b2g/gaia/pull/10369

Thomas, thank you for the effort! However, in the end I chose to merge the patch in the duplicate bug 880157 considering it includes localization and the update of unknown paired devices.
Attachment #762049 - Flags: review?(arthur.chen)
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 880157
You need to log in before you can comment on or make changes to this bug.