Closed Bug 882690 Opened 6 years ago Closed 6 years ago

getUserMedia - Unable to see connected peer in Tokbox demo (Android ↔ Desktop)

Categories

(Core :: WebRTC, defect)

24 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 877701
Tracking Status
firefox24 + fixed
fennec 24+ ---

People

(Reporter: aaronmt, Assigned: gcp)

References

()

Details

(Whiteboard: [WebRTC][android-webrtc+])

Attachments

(2 files)

Builds: Nightly (06/13) for Android and Nightly (06/13) for OS X
Devices: LG Nexus 4 (Android 4.2), Samsung Galaxy S4 (Android 4.2), HTC One (Android 4.1), MacBook Pro (OS X 10.8.4)

Pre-Req: Enable WebRTC on Nightly for Android

Steps to Reproduce

i) Connect to http://tokbox.com/opentok/webrtc/demo on desktop, share microphone and camera
ii) Share unique session to Nightly on Android, share microphone and camera

Expected:

I expected to see and hear the user media from my desktop as a connected peer on my phone
I expected to see and hear the user media from my mobile device as a connected peer on my desktop

Actual: Black screens for all connected, unable to see connected peers and unable to hear connected peers
Version: 22 Branch → 24 Branch
Can you include a logcat?
Whiteboard: [getUserMedia][android-gum?] → [WebRTC][android-webrtc+]
Assignee: nobody → gpascutto
tracking-fennec: ? → 24+
It looks like there's a general problem with calls not working at all. My test app that has no website dependencies at http://mysecondwebrtc.appspot.com/ isn't allowing video to go between peers in the Android to Desktop and Android to Android cases.

I think this is a dupe of bug 877701. We can't do calls at all right now.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 877701
No longer blocks: android-webrtc
Confirmed this is also a dupe of dupe of bug 888274.

[{url:"stun:stun.l.google.com:19302"}] is being used.
Marking this fixed given the DUP is fixed/verified on Fx24.
You need to log in before you can comment on or make changes to this bug.