Sometimes scrolling doesn't work

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
3 months ago

People

(Reporter: fitzgen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Sometimes I won't be able to scroll in the source editor. Has happened to me in the style editor and the debugger. I've tried making sure it has focus, still no go. I end up having to use the arrow keys.

Sorry I'm not sure exactly what the STR are, I just know it happens to me fairly frequently.

Comment 1

5 years ago
Was it after you undocked/docked the toolbox?
Nope, I always have it docked.
Yeah scrolling in the debugger in Nightly 25 in OSX is a dog.

STR:

1. CMD+alt+S
2. Click on a source that you have to scroll to see
3. Without clicking anywhere else, hover over the source with the cursor and try to scroll using OSX gestures (two finger scrolling)

Expected:
Smooth responsive scrolling

Actual:
Sometimes scrolling stops mid gesture
Sometimes scrolling doesn't respond to the gesture (doesn't start)

Comment 4

5 years ago
My guess is it started when we introduced OSX new scrollbars (bug 636564).

Apparently, it only happens in the Source Editor (and on OSX).

Comment 5

5 years ago
What I've noticed is that if you're scrolling by a very small amount (perhaps a pixel or two, perhaps smaller than a single line?) then no scrolling occurs at all. If your scroll event's amount is larger than some threshold (perhaps bigger than at least a single line?) then some scrolling occurs; although exactly how much scrolling occurs is difficult to gauge by eyeballing it.
Duplicate of this bug: 907178
This had been fixed by the CodeMirror switch.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.