bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Compose message window hangs on send

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: helkav, Unassigned)

Tracking

17 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon:AttachmentReminder])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 762180 [details]
tb_error_console.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130611 Firefox/23.0 (Nightly/Aurora)
Build ID: 20130611004015

Steps to reproduce:

Attempt to send an email. IMAP account, replying to mail


Actual results:

After hitting send, the message compose window froze. Every time I try to click anywhere on it it makes a soft beep. 

I could still alt-tab to the main TB window, and have got screenshots of the error console (errors, warnings and messages)

I had to kill TB to close the message window, and go back in.

I tried several times, and I reproduced the issue each time (with the same email)

Then I tried in safe mode and voila! message sending was successful. So I guess an addon / plugin / extension is causing the problem.

It is odd, as I haven't installed/updates addons for a few days (as far as I remember!) and I have been sending messages no problem. 

also tested in :

earlybird 23.0a2 - same result

daily 64bit 24.0a1 (2013-06-12) - same result

daily 32bit 24.0a1 (2013-06-12) - same result

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

when I get time I will go through my addons one by one and disable to find out what's causing the issue. However, I think this is something that has crept into the latest releases of TB o make them incompatible, as I don't believe I have added anything since the last release. 

If anyone else is experiencing this, they might help me find the cause quicker. It would  be much appreciated =:-)
(Reporter)

Comment 1

5 years ago
Created attachment 762183 [details]
error console: messages
(Reporter)

Updated

5 years ago
Attachment #762183 - Attachment description: error console: warnings → error console: messages
(Reporter)

Comment 2

5 years ago
Created attachment 762185 [details]
error console: warnings
(Reporter)

Comment 3

5 years ago
I have found the addon causing the problem. It's AttachmentReminder:

https://addons.mozilla.org/en-US/thunderbird/addon/attachment-reminder/

I have reported the addon as incompatible, although I think TB has changed something to make it incompatible as the addon has a last release date of 2008! Is it up to the developer of the addon to change their code or should TB be more backward-compatible with addons?

Comment 4

5 years ago
(In reply to hckpost from comment #3)
> Is it up to the developer of the addon to change their code or should
> TB be more backward-compatible with addons?

typically the former, it's up to the addon to conform.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Whiteboard: [addon:AttachmentReminder]
You need to log in before you can comment on or make changes to this bug.