[leo-pre-iot-br] PLMNs from Vivo (Brazil) not shown properly

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: dpalomino, Assigned: pgravel)

Tracking

unspecified
x86_64
Windows 7

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: [leo-pre-iot-br][mozilla-triage])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Device: leo
buildid: 20130529095707 (brazilian variant)

This issue has been tested in lab enviroment, using Agilent network emulators. 

1. Configure network emulator to simulate network MCC=724 (Brazil); MNC=06
2. Device registered to emulated network
3. Device should show "VIVO" network, but it shows "CTBC Telecom" indeed (which is a Vivo's competitor indeed)
4. Also failing with 724/23, showing "Amazonia Cel" instead of "VIVO"

Here you can find a table with MCC/MNC and PLMN name correspondance: 

MCC - MNC - Expected PLMN Name
724   06    VIVO
724   10    VIVO
724   11    VIVO
724   23    VIVO

As these tests are executed in RJ, no logs available yet (I'm in SP). We'll ask for logs to colleagues in RJ. 

See also bug#798008 for details. 

SE13 document from GSMA provides all the information about the PLMN names that should be shown in any case. 

Nominating leo?, this is absolutely mandatory for certification. 

Thanks!
David
Waiting on getting the logs here.
(Reporter)

Comment 2

5 years ago
Created attachment 764624 [details]
qxdm logs

see attached QXDM logs (cc'ed Ansul, just in case he can add some input here). 

we're going to ask for adb and adb radio logs.
Flags: needinfo?(anshulj)
(Reporter)

Comment 3

5 years ago
Hi again, 

Please, when the bug would be assigned, we'd ask to the developer to contact us to provide additional info (sorry, but it cannot be published in bugzilla). 

Thanks!
David

Comment 4

5 years ago
Please provide android radio logs and the main logs.
Assignee: nobody → pgravel
Flags: needinfo?(anshulj)
(Reporter)

Comment 5

5 years ago
Hi Anshul, 

We have no access to that lab now. We've asked for the logs, although maybe from vendor's local office in SP it could be easier to obtain. 

ni to Jinyoon, for checking that possibility.
Flags: needinfo?(ellio.chang)

Updated

5 years ago
Whiteboard: [leo-pre-iot-br] → [leo-pre-iot-br][mozilla-triage]

Comment 6

5 years ago
I will check it and make feedback...

Comment 7

5 years ago
This was fixed already in the latest Leo custom build.

Comment 8

5 years ago
It was tested using OEM test equipment and it works for me.
I think it can be changed to resovled status.
Flags: needinfo?(ellio.chang)
(Assignee)

Comment 9

5 years ago
Marking as resolved as per comment 7 and 8.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(In reply to leo.bugzilla.gecko from comment #7)
> This was fixed already in the latest Leo custom build.

Can you confirm what resolved this issue? Was it a new RIL or Gecko change?
(Reporter)

Comment 11

5 years ago
Hi, 

@Jinyoon, have you been able to retest this in Brazil? Can you ask to your colleagues there to do a quick retest?

Thanks!
David
Flags: needinfo?(ellio.chang)
Triage - Leo+, in case it is not already resolved it will be a blocker for IOT.
blocking-b2g: leo? → leo+
(Reporter)

Comment 13

5 years ago
Created attachment 777035 [details]
adb logcat log
(Reporter)

Comment 14

5 years ago
Created attachment 777036 [details]
adb logcat radio log

Comment 15

5 years ago
This issue was fixed as changing the part of Commercial RIL. In latest custom-build, it is not reproduced.

David, is it still reproduced? If that, please provide the information of firmware version that you are using.
Flags: needinfo?(ellio.chang)

Comment 16

5 years ago
This issue was fixed in 2013-06-04 and I retested with network equipment and not reproduced.
Please retest the latest version.
Is there anything that needs to be done before we can mark this as fixed for 1.1?
Flags: needinfo?(pgravel)
(Assignee)

Comment 18

4 years ago
Clearing stale ni, bug seems already resolved as fixed.
Flags: needinfo?(pgravel)
You need to log in before you can comment on or make changes to this bug.