[Settings][CF] There is no option menu for set the timer on CFNRy and can't update phone number when enabled

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
P1
normal
RESOLVED WONTFIX
5 years ago
4 months ago

People

(Reporter: Leo, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Reporter)

Description

5 years ago
Description:
1. There is no option menu for set the timer on CFNRy.
2. User can't update phone number when CF enabled

Repros:
Settings - Call Settings
[Case 1]
1) Go to Forward when unanswered
2) Insert a number which to the call will be forwarded. 
3) Press OK button. 
: There is no option menu for set the timer value


[Case 2]
1) Go to any CF
2) Insert a number which to the call will be forwarded. 
3) Press OK button.
4) Go to set CF and try to update phone number
: User can't update phone number

Version Info
Mozilla build ID: 20130526070207
Gaia Revision : 4d10e1297b859cacc174c0a54af61a7678d7c32d
Gecko Revision : 52341e43539a0e8b9aa77a9128cc3871439b8aa6
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo+
Assignee: nobody → arthur.chen
Jose, do we have the ability allowing users to set a time value for |forward when unanswered|?
Flags: needinfo?(josea.olivera)
The mozMobileConnection API underneath allows it. See [1]. Right now we set a default (20 seconds) value as AOSP does (to be honest there is a but about it see bug 863181). It seems a bit weird to allow the user to set the time he/she wants. AOSP doesn't allow it and the carrier usually doesn't allow the user to enable/disable this call forwarding reason. 

[1] http://mxr.mozilla.org/mozilla-central/source/dom/network/interfaces/nsIDOMMobileConnection.idl#631
Flags: needinfo?(josea.olivera)
Per comment 2, and I've checked android and iPhone, both platforms do not allow users to change the value. Leo, could you provide justification on nominating this bug for leo+?
blocking-b2g: leo+ → leo?
Flags: needinfo?(leo.bugzilla.gaia)
And it would be appreciated if case 2 could be filed as another bug. Thanks!
(In reply to Arthur Chen [:arthurcc] from comment #4)
> And it would be appreciated if case 2 could be filed as another bug. Thanks!

There have been many bugs requesting case #2. Case #2 is not a bug but the way the call forwarding UI works. If the user wants to change the number for a call forwarding reason already enabled he/she needs to disable it before changing the number.
The request of case 2 sounds reasonable. However it is an UX issue but may not be a blocker.
(Reporter)

Updated

5 years ago
Flags: needinfo?(leo.bugzilla.gaia)
Priority: -- → P1

Updated

5 years ago
Duplicate of this bug: 881858

Comment 8

5 years ago
Leo did not provide justification as requested in comment 3, so not blocking.
blocking-b2g: leo? → -
(Reporter)

Updated

5 years ago
Depends on: 903330
Assignee: crh0716 → nobody

Comment 9

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.