[System][Music] The volume of the player changes the profile of the handset to vibrate or silent.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System
P1
major
RESOLVED WONTFIX
5 years ago
4 months ago

People

(Reporter: leo.bugzilla.gecko, Assigned: alive)

Tracking

unspecified
1.1 QE4 (15jul)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Reporter)

Description

5 years ago
Description:
[Must have some music inserted]
1. Make sure that the media volume is not mute > Go to "Music"
2. Decrease the ringer volume to vibrate or silent in home screen
3. Play one song
3. Check the behavior of the status bar.

Expected:
The volume of the player should not change the profile of speaker to vibrate or silent.

Actual:
The volume of the player changes the profile of speaker  to vibrate or silent.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?

Comment 1

5 years ago
If you make silent or vibrate in home screen, you can check that the "normal/content"volume set to 0.
(Reporter)

Updated

5 years ago
blocking-b2g: leo? → leo+
Target Milestone: --- → 1.1 QE3 (24jun)
I totally don't understand this bug...what do you mean by "The volume of the player should not change the profile of speaker to vibrate or silent"?

(In reply to Seil Park from comment #1)
> If you make silent or vibrate in home screen, you can check that the
> "normal/content"volume set to 0.

This is intentional. It's entering silent mode both notification channel and content channel then.
Assignee: nobody → alive

Comment 3

5 years ago
(In reply to Alive Kuo [:alive] from comment #2)
> This is intentional. It's entering silent mode both notification channel and
> content channel then.

Is it right that It set content channel to volume 0?
We understood that the silent mode is for notificaition/normal like touch sound/ringer

There was something strange about it in UX.

1. First, set the media volume to maximum 15. set silent mode and play music.
and then you can`t hear the music. but after volume-up, you can hear the loud sound suddenly.

2. content volume db is not changed. but content channel set volume "0". 
and then You can`t hear the music till volume up event if you plug headset. 

We don`t know which one it is right because of using both normal/content channel.
If the two cases are not problem, I will follow your opinion.
(In reply to Seil Park from comment #3)
> (In reply to Alive Kuo [:alive] from comment #2)
> > This is intentional. It's entering silent mode both notification channel and
> > content channel then.
> 
> Is it right that It set content channel to volume 0?
> We understood that the silent mode is for notificaition/normal like touch
> sound/ringer
> 
> There was something strange about it in UX.
> 
> 1. First, set the media volume to maximum 15. set silent mode and play music.
> and then you can`t hear the music. but after volume-up, you can hear the
> loud sound suddenly.

Yes, we could change this if UX don't feel good. Don't remember the previous value.

> 
> 2. content volume db is not changed. but content channel set volume "0". 
> and then You can`t hear the music till volume up event if you plug headset. 

No, it's changed.
So you mean
1) Enter silent mode at homescreen
2) Goto music and start playing => No sound
3) Insert headset => sounding?
I cannot reproduce...
If so, it's a bug.

> 
> We don`t know which one it is right because of using both normal/content
> channel.
> If the two cases are not problem, I will follow your opinion.

Comment 5

5 years ago
(In reply to Alive Kuo [:alive] from comment #4)
> Yes, we could change this if UX don't feel good. Don't remember the previous
> value.
> 
I think remembering the previous is better than that.
I`m wondering about the loud sound like CE Safty (Bug 863267).

Can you only set normal channel except content when set silent/vibrate mode.
(In reply to Seil Park from comment #5)
> (In reply to Alive Kuo [:alive] from comment #4)
> > Yes, we could change this if UX don't feel good. Don't remember the previous
> > value.
> > 
> I think remembering the previous is better than that.
> I`m wondering about the loud sound like CE Safty (Bug 863267).

OK good catch. So this is the problem...hmm

> 
> Can you only set normal channel except content when set silent/vibrate mode.

No, they are the same channel.

Comment 7

5 years ago
I think so. It is not easy to resolve the issue. 
I`d like to suggest two case scenario.

1. silent/vibrate mode only includes notification/ringer. 
Because the both(normal/content) volume is restore when volume-up on media state,
I think excluding normal/content is better. but normal channel has to keep volume even though silent mode is on.

2. It maintains the current status
But, It can`t hear the sound by headset/speaker without clicking volume key.

I look forward to hearing from you.
(In reply to Seil Park from comment #7)
> I think so. It is not easy to resolve the issue. 
> I`d like to suggest two case scenario.
> 
> 1. silent/vibrate mode only includes notification/ringer. 
> Because the both(normal/content) volume is restore when volume-up on media
> state,
> I think excluding normal/content is better. but normal channel has to keep
> volume even though silent mode is on.

That's the original behavior before bug 819842...
There're lots of bugs based on it. I really don't think now we should back-out it.
https://bugzilla.mozilla.org/show_bug.cgi?id=819842
What people mostly complains is when they enter silent mode(they think so), the sound of keyboard or DTMF tone or any normal channel is not silent.

> 
> 2. It maintains the current status
> But, It can`t hear the sound by headset/speaker without clicking volume key.

I personally vote for this and:
When in silent mode, if the headset is inserted, make content channel leave silent mode(go to CE warning volume or 1).

Anyway we need UX input.

> 
> I look forward to hearing from you.
Flags: needinfo?(kyee)

Comment 9

5 years ago
(In reply to Alive Kuo [:alive] from comment #8)
> (In reply to Seil Park from comment #7)
> > I think so. It is not easy to resolve the issue. 
> > I`d like to suggest two case scenario.
> > 
> > 1. silent/vibrate mode only includes notification/ringer. 
> > Because the both(normal/content) volume is restore when volume-up on media
> > state,
> > I think excluding normal/content is better. but normal channel has to keep
> > volume even though silent mode is on.
> 
> That's the original behavior before bug 819842...
> There're lots of bugs based on it. I really don't think now we should
> back-out it.
> https://bugzilla.mozilla.org/show_bug.cgi?id=819842
> What people mostly complains is when they enter silent mode(they think so),
> the sound of keyboard or DTMF tone or any normal channel is not silent.

I agree, the expectation is that when you adjust the volume to 0 or vibrate mode, you would want all sounds from the device including content to be set to 0.  The only exception to this would be telephony and alarm.

> 
> > 
> > 2. It maintains the current status
> > But, It can`t hear the sound by headset/speaker without clicking volume key.
> 
> I personally vote for this and:
> When in silent mode, if the headset is inserted, make content channel leave
> silent mode(go to CE warning volume or 1).
> 
> Anyway we need UX input.


I think it would make sense to set the volume to 1.   The alternative is to restore the volume to it's previous setting.   I feel that if we do this though, that it may surprise users.
Flags: needinfo?(kyee)

Comment 10

5 years ago
(In reply to Casey Yee [:cyee] from comment #9)
> I agree, the expectation is that when you adjust the volume to 0 or vibrate
> mode, you would want all sounds from the device including content to be set
> to 0.  The only exception to this would be telephony and alarm.

OK, That makes sense. I`m worried about normal volume. 
I suggested this way because many mobile OS excepts content volume, because the content/normal volume is restore from silent/vibrate by clicking the key. 

> I think it would make sense to set the volume to 1.   The alternative is to
> restore the volume to it's previous setting.   I feel that if we do this
> though, that it may surprise users.

I think setting to 1 give the user the confusion. The main claim is that It may surprise the user. 
The alternative method gives the volume the progressive changes. 
For example, original volume is 10 level , 0 -> 3 -> 6 -> 9 -> 10 (1 second intervals)
I would like to know if It is available or not.

If it is not easy, It would be better to keep the current status.

Comment 11

5 years ago
I have another question. 
When It set media volume to zero, Is it right that vibrator/silent mode is set? 
I don`t know that the intended scenario or the bug?
Flags: needinfo?(alive)

Comment 12

5 years ago
(In reply to Seil Park from comment #11)
> I have another question. 
> When It set media volume to zero, Is it right that vibrator/silent mode is
> set? 
> I don`t know that the intended scenario or the bug?
Maybe It is Bug 882053 - [Audio] Sound mode of indicator change when changeing volumne in youtube site
thanks.

Updated

5 years ago
Flags: needinfo?(alive)
Is there any accurate stuff need to be fixed in this bug now?

Comment 14

5 years ago
No, there is now no stuff. So I asked it is available to fix this without the risk.
(In reply to Seil Park from comment #14)
> No, there is now no stuff. So I asked it is available to fix this without
> the risk.

Sorry I couldn't get your point...
IMO the only problem remaining is
1) Go to silent mode
2) Insert headset
3) Play music
4) Press volume up

Expected
* CE warning shows instead of go to volume 15

Actual
* Content volume goes to 15(because it's restored from silent mode) when headset inserted.
(In reply to Seil Park from comment #10)
> (In reply to Casey Yee [:cyee] from comment #9)
> I think setting to 1 give the user the confusion. The main claim is that It
> may surprise the user. 
> The alternative method gives the volume the progressive changes. 
> For example, original volume is 10 level , 0 -> 3 -> 6 -> 9 -> 10 (1 second
> intervals)

I don't understand this proposal.

Why need an interval?
My proposal is use CEMAX-1 if 
(1) the restored volume exceeds CEMAX-1
(2) User has not yet turn off the CE Warning.

Comment 17

5 years ago
> Why need an interval?
> My proposal is use CEMAX-1 if 
> (1) the restored volume exceeds CEMAX-1
> (2) User has not yet turn off the CE Warning.

OK, I see. I found what your comment means. 
----------------------------------------------------
[Test Case 1]
content volume is under 9
set Silent mode
plug headset
play music

[Test Case 2] ->If it will show CE Warning popup.
content volume is over 10
set Silent mode
plug headset
play music 

[Test Case 3] -> turn off the CE Warning popup
content volume is over 10
set Silent mode
plug headset
play music 
----------------------------------------------------
[Test Case 1, 3] music is mute , [Test Case 2] music is set by lev 10

I said [Test Case 1, 3] need the progressive changes when press volume key. 
Because It is difficult to restore to the original volume when music is played , I suggested the alternative

I think [Test Case 2] is ok.
I testes and the CE warning does show after restoring the content volume.
I think we don't need to block on this bug.
blocking-b2g: leo+ → leo?
Leo told me about this today.

So now I understand what's they are worrying here:
When user dismisses the CE warning dialog, if he triggers silent mode in homescreen,
and back to music w/ headset again and using volume rocker, the restoring mechanism would scare the user if the restored volume is 15 or something like this.

I think no matters set to volume 1 or restore to 3,6,9,12 is not a good UX,
the latter makes the user confuse why the volume indicator jump in a strange way.

This still needs UX input, but in the end if we don't have a good solution,
my proposal is in this case, use CEWarningVolume-1 if the restored volume is more than CEWarning...
Flags: needinfo?(kyee)
Leo, feel free to leo+ this again. I leo?ed this just because I don't understand the problem here..
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Updated

5 years ago
blocking-b2g: leo? → leo+
Flags: needinfo?(leo.bugzilla.gaia)

Updated

5 years ago
Whiteboard: [TD-44130]
If we don't have patches up for this in a week, this will start to feel at risk for v1.1.
Target Milestone: 1.1 QE3 (26jun) → 1.1 QE4 (15jul)
(In reply to Alex Keybl [:akeybl] from comment #21)
> If we don't have patches up for this in a week, this will start to feel at
> risk for v1.1.

I think we need decisions beyond patches.
However, personally I don't think this is a blocker.
Flags: needinfo?(kyee) → needinfo?(firefoxos-ux-bugzilla)

Updated

5 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)

Updated

5 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 23

5 years ago
Let's discuss it to triage
blocking-b2g: leo+ → leo?

Comment 24

5 years ago
Assigning to Rob since Rob worked on the CE volume warning previously. Rob, feel free to bounce to Casey if necessary.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(rmacdonald)
Still don't have a patch ready. Given comment 21, not blocking.
blocking-b2g: leo? → -
Not sure if this bug is still relevant but flagging Jenny just in case.
Flags: needinfo?(rmacdonald) → needinfo?(jelee)

Comment 27

4 years ago
I tested the use case

1. Make sure that the media volume is not mute > Go to "Music"
2. Decrease the ringer volume to vibrate or silent in home screen
3. Play one song (no sound)
4. Hardware key volume up (music playing, volume level starts from 1)

and found the actual behavior is acceptable. So I don't think there's an issue here, thanks!
Flags: needinfo?(jelee)

Comment 28

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.