Closed Bug 883031 Opened 7 years ago Closed 7 years ago

[MMS] Not possible to recieve MMS using Orange PL SIM card

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P2)

ARM
Gonk (Firefox OS)

Tracking

(blocking-b2g:leo+)

RESOLVED DUPLICATE of bug 883022
1.1 QE3 (26jun)
blocking-b2g leo+

People

(Reporter: leo.bugzilla.gaia, Assigned: ctai)

References

Details

(Whiteboard: [TD-43289])

Attachments

(1 file)

1. Title: Not possible to recieve MMS using Orange PL SIM card
2. Precondition: (1) SMS app should be working.
                 (2) Orange PL SIM card inserted (260-03), wifi off, 3G on
3. Tester's Action: 1) Send MMS to FFOS device from android device 
4. Detailed Symptom (ENG.) : The device is not able to download the content of the MMS (forever 'downloading')
5. Expected: MMS should be recieved
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train: Reproduced on v1-train and master
8. Gaia Revision:  bd07ce233160a0e6325bf736769772a9d2273458
9. Personal email id: sasikala.paruchuri8@gmail.com
blocking-b2g: --- → leo+
Whiteboard: [TD-43289]
Target Milestone: --- → 1.1 QE3 (24jun)
Assignee: nobody → ctai
Priority: -- → P2
Could you please follow below steps to get log for me? And please post the APN settings of DATA/MMS. Those informations will be very useful for me because of I have no Orange PL SIM card. 

rm user.js 2>/dev/null
adb remount
adb pull /system/b2g/defaults/pref/user.js user.js
sed -i -e '$ a\
pref("ril.debugging.enabled", true);\
pref("mms.debugging.enabled", true);
' user.js
adb push user.js /system/b2g/defaults/pref/user.js
adb shell reboot

## update for replacing user.js script
Flags: needinfo?(leo.bugzilla.gaia)
Hi,
Is it ok if i send the logs which are available with me to your mail id(ctai@mozilla.com)?
Thanks
Flags: needinfo?(leo.bugzilla.gaia)
Sure, no problem.

(In reply to Leo from comment #2)
> Hi,
> Is it ok if i send the logs which are available with me to your mail
> id(ctai@mozilla.com)?
> Thanks
sasikala, Bug 884146 might fix this problem. You still can send the log to me. I can check the log to see the error code.
Flags: needinfo?(leo.bugzilla.gaia)
Hi Chia-hung Tai,
We have already requested the tester to provide the logcat information as we dont have Orange PL SIM card.
Once i will get the logs send you immediately.
Thanks for your support.To which country this FarEasTone sim card belongs?
Thanks,
Leo
Flags: needinfo?(leo.bugzilla.gaia)
(In reply to Leo from comment #5)
> Thanks for your support.To which country this FarEasTone sim card belongs?

Taiwan.
Attached file Logcat logs attached
Hi,
Please find the log cat logs attached for the defect
Thanks
Are you guys use QC RIL?
Flags: needinfo?(leo.bugzilla.gaia)
Hi Chai-hung Tai,
We are using QC RIL.
Flags: needinfo?(leo.bugzilla.gaia)
For receive MMS issue via Orange PL sim card, the log shows http status 0. After Bug 884146 landing might resolve this issue. Please retry this test later(now it is landed on birch, will be landed in b2g18 about two day later).
Flags: needinfo?(leo.bugzilla.gaia)
From the log, it shows this happened after sending MMS fail(first time sending successfully, then fail in the following MMS sending/receiving). So might something wrong in APN(see bug 883022) cause we can't receive MMS. Can Leo do the MMS receiving first on a fresh build cellphone? Also please attach the log with MMS/RIL log and use adb logcat -v time -b main -b radio. That will be very helpful. Thanks.
Depends on: 883022
This bug should the same root cause as 883022.
Requested Tester for the logs.
Will update you once we will get the logs.
Thanks
Flags: needinfo?(leo.bugzilla.gaia)
From the log, this bug should be a duplicated of bug 883022. According to https://bugzilla.mozilla.org/show_bug.cgi?id=883022#c7. , this bug should be fixed in AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.135+. Please try again you guys use this version of QC RIL. Thanks.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 883022
You need to log in before you can comment on or make changes to this bug.