[tara] B2G RIL: Calling updateCellBroadcastConfig causes modem to crash.

RESOLVED WONTFIX

Status

Firefox OS
General
--
critical
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: sam.hua, Unassigned)

Tracking

(Blocks: 1 bug, {crash, stackwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g-crash])

(Reporter)

Description

5 years ago
in ril_worker.js

  // TODO hardcoded for now (see bug 726098)
  let cdma = false;

  if ((this.radioState == GECKO_RADIOSTATE_UNAVAILABLE ||
       this.radioState == GECKO_RADIOSTATE_OFF) &&
       newState == GECKO_RADIOSTATE_READY) {
    // The radio became available, let's get its info.
    if (cdma) {
      this.getDeviceIdentity();
    } else {
      this.getIMEI();
      this.getIMEISV();
    }
    this.getBasebandVersion();
    this.updateCellBroadcastConfig();
  }

this.updateCellBroadcastConfig() will send RIL_REQUEST_GSM_SMS_BROADCAST_ACTIVATION to modem, and it causes the modem to crash.

any modification for this hardcode?

Comment 1

5 years ago
Hi Yoshi,

Can you help to clarify this issue?
Very thanks,
Flags: needinfo?(allstars.chh)

Updated

5 years ago
Blocks: 883051
(In reply to sam.hua from comment #0)
> in ril_worker.js
> 
>   // TODO hardcoded for now (see bug 726098)
>   let cdma = false;
> 
>   if ((this.radioState == GECKO_RADIOSTATE_UNAVAILABLE ||
>        this.radioState == GECKO_RADIOSTATE_OFF) &&
>        newState == GECKO_RADIOSTATE_READY) {
>     // The radio became available, let's get its info.
>     if (cdma) {
>       this.getDeviceIdentity();
>     } else {
>       this.getIMEI();
>       this.getIMEISV();
>     }
>     this.getBasebandVersion();
>     this.updateCellBroadcastConfig();
>   }
> 
> this.updateCellBroadcastConfig() will send
> RIL_REQUEST_GSM_SMS_BROADCAST_ACTIVATION to modem, and it causes the modem
> to crash.
> 
> any modification for this hardcode?

You mean you are using CDMA and wonder why this flag (cdma) is false?
In this case, I think b2g18 is not yet ready for CDMA, so this flag is always false(on b2g18).

Or you are asking why RIL will call updateCellBroadcaseConfig?
That's because we support CellBroadcast.
Or do you mean RIL shouldn't call this function at all, because your modem doesn't support cell broadcast?

Or you are asking why calling cellBroadcast will cause modem crash?
We don't own the modem module, I think you should forward your question to modem side.
Flags: needinfo?(allstars.chh)
(Reporter)

Comment 3

5 years ago
no, i know cdma is false.
After we set airmode off,gecko will turn on radio power and will get UNSOLICITED_RESPONSE_RADIO_STATE_CHANGED from modem.
this.updateCellBroadcastConfig() will be called and send RIL_REQUEST_GSM_SMS_BROADCAST_ACTIVATION to modem.but modem of tara will crash after it recieves the RIL_REQUEST_GSM_SMS_BROADCAST_ACTIVATION.

I don't know updateCellBroadcastConfig() is necessary or not at this time. If it is necessary,we will let our modem team to check their problem.
NI? to Vicamo as he implemented Cell broadcast,
Vicamo, can you help to check comment 3?
Flags: needinfo?(vyang)
Summary: [tara]the hardcode for bug 726098 causes modem to crash. → [tara] B2G RIL: Calling updateCellBroadcastConfig causes modem to crash.

Comment 5

5 years ago
We need a stack trace (see https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#Getting_crashes_off_the_Device).
Severity: normal → critical
Flags: needinfo?(sam.hua)
Keywords: crash, stackwanted
Whiteboard: [b2g-crash]
(Reporter)

Comment 6

5 years ago
Even if we find the code witch cause the crash in modem, but it should be modified by modem team.

what i want is :
I don't know updateCellBroadcastConfig() is necessary or not at this time. If it is necessary,we will let our modem team to check their problem.
Flags: needinfo?(sam.hua)
That's for resetting Cell Broadcast configs after airplane mode off.  You can find the same thing in Android packages/apps/CellBroadcastReceiver/src/com/android/cellbroadcastreceive/CellBroadcastReceiver.java:onReceiveWithPrivilege().
Flags: needinfo?(vyang)
(Reporter)

Comment 8

5 years ago
Ok,i will give this info to our modem team.

thanks!
Please re-open if you find any open document saying such behaviour is forbidden/wrong/...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
Add Bruce, please check spreadtrum modem issue.
You need to log in before you can comment on or make changes to this bug.