[tara]should deactive data call before set radio power off

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: sam.hua, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Ubuntu/11.04 Chromium/18.0.1025.151 Chrome/18.0.1025.151 Safari/535.19

Steps to reproduce:

1. set apn and the MS can use data service.
2. set air mode on.
3. set air mode off.



Actual results:

MS can find the network but couldn't use data service


Expected results:

MS can find the network and use data service
(Reporter)

Comment 1

5 years ago
To make tara modem to work, ffos should deactive the data call before send the radio power off .

RadioInterfaceLayer.js:
setRadioEnabled: function setRadioEnabled(value) {
    debug("Setting radio power to " + value);
    this._changingRadioPower = true;
	if (!value)		//if closing radio,should close datacall first.
	{
	    this.dataNetworkInterface.disconnect();
	};	
    this.worker.postMessage({rilMessageType: "setRadioPower", on: value});
  },
CCing Edgar on this.

Comment 3

5 years ago
(In reply to sam.hua from comment #0)
> User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like
> Gecko) Ubuntu/11.04 Chromium/18.0.1025.151 Chrome/18.0.1025.151 Safari/535.19
> 
> Steps to reproduce:
> 
> 1. set apn and the MS can use data service.
> 2. set air mode on.
> 3. set air mode off.
> 
> 
> 
> Actual results:
> 
> MS can find the network but couldn't use data service
> 
> 
> Expected results:
> 
> MS can find the network and use data service

Some questions first before asking RIL expert to help on this case.

Q1: What gaia/gecko branch do you use? ex: gaia: v1-train, gecko: b2g18.

Q2: Please provide gaia/gecko version based on Mozilla git you used to test.

Q3: Refer to the last step of reproducing way - "set air mode off",
    Since we set air mode to off, why do we expect "MS can find the network and use data service". Is this really a reproducing steps?

Thanks.

Updated

5 years ago
Blocks: 883051
(Reporter)

Comment 4

5 years ago
Q1:
yes, gaia:v1-train,gecko:b2g18, sorry to forget this information.

Q2:
gecko:ce85ace50ad171d3d7a8c00fc5a16d2494aba509
gaia:486b7fdfa1fcd4494da67b9d4c556cbd71613727

Q3:
yes, setting air mode to off means to open the radio and connect to network. and MS can use circuit and data services.

Comment 5

5 years ago
(In reply to sam.hua from comment #1)
> To make tara modem to work, ffos should deactive the data call before send
> the radio power off .
> 
> RadioInterfaceLayer.js:
> setRadioEnabled: function setRadioEnabled(value) {
>     debug("Setting radio power to " + value);
>     this._changingRadioPower = true;
> 	if (!value)		//if closing radio,should close datacall first.
> 	{
> 	    this.dataNetworkInterface.disconnect();
> 	};	
>     this.worker.postMessage({rilMessageType: "setRadioPower", on: value});
>   },

Some questions:

1. In this case, if ffos de-active the data call before radio off, does this mean ffos should active the data call back by itself when radio power on? Or modem will cover this?

2. If ffos does not de-active data call when radio off, but only try to active the data call again when radio power on, what will happen in tara modem?

Thanks
(Reporter)

Comment 6

5 years ago
Q1: modem will cover it.
    I check the code in our android project, it deactives data call and wait until it done, then send radio power off request to modem. 

Q2: tara modem could attach the network and setup data call again, but failed to use the data service just like use browser to navigator the web site. i guess that tara modem has some problems on its process.
Add Bruce, please check spreadtrum modem issue.
Hi Sam,

May I know the current status of the modem issue Q2? Has this been fixed? And once this fixed, does that mean it is fine that ffos does NOT need to de-activate data call before radio off? Thanks!
Flags: needinfo?(sam.hua)
(Reporter)

Comment 9

5 years ago
yes.
It's ok now.
Flags: needinfo?(sam.hua)
(In reply to sam.hua from comment #9)
> yes.
> It's ok now.

So can I say that it's also okay on fugu device? Thanks for your reply!
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #10)
> (In reply to sam.hua from comment #9)
> > yes.
> > It's ok now.
> 
> So can I say that it's also okay on fugu device? Thanks for your reply!

And since it's okay now, should we close this bug?
(Reporter)

Comment 12

5 years ago
yes.close it

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: General → RIL
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.