If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

possible_duplicates() ignores strings of the form "2.0.3"

RESOLVED DUPLICATE of bug 970184

Status

()

Bugzilla
WebService
--
enhancement
RESOLVED DUPLICATE of bug 970184
4 years ago
4 years ago

People

(Reporter: Marcus Moeller, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130516142033

Steps to reproduce:

It seems that Bugzilla only checks for the title of the bug when showing Possible Duplicates.

E.g. I have created a bug called: 

update to 1.1.0

and the existing bug for the same component called:

mypaint-1.1.0 is available

has not been displayed in the list.

Of course there are only 5 similar characters, while 19 are different, but these might be enough if the comp is the same.

Comment 1

4 years ago
The reason it ignores 1.1.0 is because we split words on punctuation characters and then ignore strings shorter than 3 characters.
Assignee: create-and-change → webservice
Severity: normal → enhancement
Component: Creating/Changing Bugs → WebService
Summary: RFE: Possible Duplicates functionality could be improved → possible_duplicates() ignores strings of the form "2.0.3"
(Reporter)

Comment 2

4 years ago
Thanks for pointing the current behaviour our. Could we perhaps improve the 'ignore' logic in such a way that numbers (which are most often version numbers) are not ignored, even if they are only one digit?

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
Duplicate of this bug: 970184
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 970184
You need to log in before you can comment on or make changes to this bug.