Closed Bug 883096 Opened 7 years ago Closed 7 years ago

Crash at nsEventListenerManager::GetListenerInfo

Categories

(Core :: DOM: Events, defect, critical)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla24

People

(Reporter: past, Assigned: smaug)

References

Details

(Keywords: crash)

Crash Data

Attachments

(3 files)

Working on bug 832982, I came across a crash in nsEventListenerManager::GetListenerInfo. I have attached a scratchpad that reliably reproduces the crash when run. Uncommenting the conditional avoids the crash, at the cost of limited access to registered event listeners.

It apparently isn't just calling getListenerInfoFor(window) that causes the crash, but the call must be inside an addListenerForAllEvents() handler, too.
Ah, I see, we crash because there is allevents listeners, and try to get listener list
Severity: normal → critical
Crash Signature: [@ nsEventListenerManager::GetListenerInfo(nsCOMArray<nsIEventListenerInfo>*)]
Keywords: crash
I can confirm that this patch fixes the crash for me.
Attachment #762601 - Flags: review?(jst) → review+
https://hg.mozilla.org/mozilla-central/rev/d22a6e206de0
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
You need to log in before you can comment on or make changes to this bug.