[Clock][Alarm] Adding a new alarm with has no effect

RESOLVED FIXED

Status

Firefox OS
Gaia::Clock
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Bebe, Assigned: iliu@mozilla.com, ianliu.moz@gmail.com)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:
Open the click app
tap new alarm 
add a alarm name and time
tap done

Actual:
No alarm has been added 

Ecpected:
A alarm with the setup values is added 


I'm using the engineering build from https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-central-unagi-eng/latest/unagi.zip 
14.06.2012

Comment 1

5 years ago
Bebe, please be more specific about the Gecko and Gaia commits.

You can get them from the sources.xml file.
(Reporter)

Comment 2

5 years ago
gecko   revision="64b502c512a059c58da80924968136713fe6f8c3"
gaia    revision="30f31d7dc5f81eb0c0e7980c44aad3b0a56f5a9c"
I looked in the logcat and I see this when I try to create an alarm:

E/GeckoConsole(  614): [JavaScript Error: "TypeError: minute is undefined" {file: "app://clock.gaiamobile.org/gaia_build_defer_index.js" line: 172}]
Severity: normal → major
blocking-b2g: --- → leo?
Unfortunately, I cannot reproduce the issue on build 20130616030713(mozilla-central-unagi-eng).
Keywords: qawanted
==> koi because this is a bug on central, not v1-train.
blocking-b2g: leo? → koi?

Comment 6

5 years ago
:ianliu, more accurate STR:

1. Open Clock app
2. Click 'add new alarm'
3. Do not increase the time, do not set repeat, leave all defaults
4. Type alarm time
5. Click done.

Actual: app returns to Clock screen and no countdown banner or note to the user is shown.

Expected: Alarm is set for the time in the 'new alarm' field but for the following day. (this is the behaviour of v1.0.1 for example).

The app does not let you set an alarm to anything less than one hour in the future of the current time. If the time is less than the hour of the current time (ie if it is 9am and you try and set any alarm time <10am) after using the spinner the time is not set into the time field.

The validation around the alarm time field seems to be too strict and worse still is that no error messages are shown to the user.
Flags: needinfo?(iliu)

Updated

5 years ago
Keywords: qawanted

Comment 7

5 years ago
err sorry :ianliu, step 4 above should read:

4. Type alarm *time*  !

Pardon!

Comment 8

5 years ago
err sorry :ianliu, step 4 above should read:

4. Type alarm *nane*  !

Pardon!

Comment 9

5 years ago
*name* !

(gee I wish we could delete comments!)
I guess this issue has the same root cause with Bug 883751.
With m-c, Gecko would not allow you to set value to a <input type="time"> if the format is incorrect. 
(The format should be in HH:MM.)

With the following line when trying to init  <input type="time">, it is possible that the format would be "6:34", which make the init process has no effect on the input value.
https://github.com/mozilla-b2g/gaia/blob/master/apps/clock/js/alarm_edit.js#L239
Created attachment 771906 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10823

Pointer to Github pull-request
(Assignee)

Updated

5 years ago
Assignee: nobody → iliu
Flags: needinfo?(iliu)
Comment on attachment 771906 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10823

* Revise the incorrect time format for input type="time"

Rudy,
Could you please help to review my pr? Thank you.
Attachment #771906 - Flags: review?(rlu)
Comment on attachment 771906 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10823

r=me.
I have a suggestion commented on the pull request.

Thanks for taking care of this.
Attachment #771906 - Flags: review?(rlu) → review+
Thanks for your reviewing effort and patience on the test. I have revised the pr according your suggestion.
Zac, 

I'm sorry to handle the issue late. Thanks so much for the such detail repo-steps. It's really useful for me:) 

Since the pr is landed, we can close the issue now.
master:  d4e2125175c992ace8375adffb514f3a2df29cac
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g18: --- → unaffected
Resolution: --- → FIXED

Comment 16

5 years ago
No problem Ian, we'll be able to check this in a few hours time when the nightly build comes out!
Clearing blocking flag -- no need for nomination if this has already landed on master.
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.