Gtk warning at installation

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: fleona, Assigned: slogan)

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.1+) Gecko/20010628
BuildID:    2001062814

Gtk-CRITICAL **: file gtkwidget.c: line 1510 (gtk_widget_hide): assertion
`widget != NULL' failed.

Reproducible: Always
Steps to Reproduce:
1.Install



Actual Results:  Get that warning

Expected Results:  No warning

shell-init: could not get current directory: getcwd: cannot access parent
directories: No such file or directory
/usr/local/mozilla/run-mozilla.sh /usr/local/mozilla/mozilla-bin -installer
shell-init: could not get current directory: getcwd: cannot access parent
directories: No such file or directory

This is new of this build. Old builds didn't have this
Also i noticed that the browser is almost 2.5 megs smaller

Comment 1

17 years ago
over to Samir.
Assignee: ssu → sgehani
(Reporter)

Comment 2

17 years ago
Well, about the 2.5mb less, that was just a comment. I love that :) I know
that's because of the recent landings in stripping the linux binaries
I still dont like windows version being smaller :( but i will have to manage

Actually, the gtkwarning has been there always, but in this build now it shows
up a little bit more info

The directory thing it's brand new, but it isn't causing any problems
(Assignee)

Comment 3

17 years ago
assigning to me
Assignee: sgehani → syd

Updated

17 years ago
QA Contact: gemal → gbush
(Assignee)

Comment 4

17 years ago
Does this happen during install, or when running mozilla after install?
(Reporter)

Comment 5

17 years ago
It happens when you click the button that starts the installation (after
choosing components and stuff)
(Reporter)

Comment 6

17 years ago
Marking NEW to make little attention
Also see bug 88030

Comment 7

17 years ago
Installing Mozilla 0.9.2 (Build ID 2001062823) on a x86 Debian 2.2 system
(all stable updates applied) in my user home directory, I see the same warning:

Here is the log of my installation:

23:41:52 marc /home/marc/mozilla0.9.2/mozilla-installer
./mozilla-installer

Gtk-CRITICAL **: file gtkwidget.c: line 1507 (gtk_widget_hide): assertion
`widget != NULL' failed.
/home/marc/mozilla0.9.2/run-mozilla.sh /home/marc/mozilla0.9.2/mozilla-bin
-installer
23:46:38 marc /home/marc/mozilla0.9.2/mozilla-installer
MOZILLA_FIVE_HOME=/home/marc/mozilla0.9.2
  LD_LIBRARY_PATH=/home/marc/mozilla0.9.2:/home/marc/mozilla0.9.2/plugins:.:
     LIBRARY_PATH=/home/marc/mozilla0.9.2:/home/marc/mozilla0.9.2/components
       SHLIB_PATH=/home/marc/mozilla0.9.2
          LIBPATH=/home/marc/mozilla0.9.2
       ADDON_PATH=/home/marc/mozilla0.9.2
      MOZ_PROGRAM=/home/marc/mozilla0.9.2/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
shell-init: could not get current directory: getcwd: cannot access parent
directories: No such file or directory
*** QfaServices is being registered
*** Registering -chat handler.
*** Registering x-application-irc handler.
*** Registering irc protocol handler.
Inside Migrate Profile routine.
AutoMigration failed. Let's create a default 5.0 profile.
ProfileManager : CreateNewProfile
Profile Name: default
Profile Dir: /home/marc/.mozilla
 I am inside the initialize
 Hey : You are in QFA Startup 
(QFA)Talkback loaded Ok.

Comment 8

17 years ago
Marking NEW but i think this is a dupe.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

17 years ago
*** Bug 92312 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
Bug 92313 isn't entierly a dupe because that has some other warnings that I only
think show up in the net installer:

Gtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage):
assertion `percentage >= 0 && percentage <= 1.0' failed.
[repeated 19 times]

Comment 11

17 years ago
I meant bug 92312. I marked that one a dupe of bug 83478 instead of this one.
(Assignee)

Updated

17 years ago
Target Milestone: --- → M1
(Assignee)

Updated

17 years ago
Target Milestone: M1 → Future

Comment 12

17 years ago
Is anyone working on this? It is quiet visible as it's the first thing people
see when they intall mozilla.

Comment 13

15 years ago
Reporter:

Does this bug exists in newer (1.5) builds? If not, then please close the bug as
WorksForMe.

Comment 14

15 years ago
*** Bug 104776 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
no reports of problems here for almost 2 years...
marking WORKSFORME

please REOPEN if you are still seeing this.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 16

15 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.