Closed Bug 883225 Opened 9 years ago Closed 9 years ago

Console input should be present in debugger pane

Categories

(DevTools :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 862558

People

(Reporter: irakli, Unassigned)

Details

One thing that I absolutely hate about current UX is that while debugging something I have to keep jumping between console and debugger panes to do a manual frame inspection, by which I mean execute some JS code. There is a watch thingy, but it's feels awkward to type expressions there specially if there are multiple expression you wanna run and they also hang out there for the rest of the time.

Scratchpad not executing in the same context (see Bug 825039) makes it even more irritating). Also to be honest I'm not sure that fixing scratchpad would actually do it, since pane switching will be replaced by window switching which is little better since you can at least see both
We are on it and trying to find the best possible way to do this.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 868163
Oops! I meant bug 835899
Duplicate of bug: 835899
Nopes. (I must be sleeping here)
Duplicate of bug: split-console
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.