Closed Bug 883287 Opened 6 years ago Closed 6 years ago

"Add Search Engine" context menu prompt has "null" message

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 24

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

(Keywords: regression)

Attachments

(2 files)

See screenshot.
Assignee: nobody → margaret.leibovic
Attached image screenshot
Somehow that didn't attach.
I was debating whether to fix this here on in _getPrompt, but I decided it would be better to fix the more generic case. I highly doubt developers will ever want "null" to show up somewhere, but if they do, they can just pass in the string "null" ;)

This also adds a check for null for buttons, since we can't do anything useful with null (I checked and it looks like we just create and empty array with that).
Attachment #762868 - Flags: review?(wjohnston)
Duplicate of this bug: 883812
Attachment #762868 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/43ef3d954e3d
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
You need to log in before you can comment on or make changes to this bug.