[Marketplace] Marketplace Privacy Policy and Terms of Use pages never finish loading if scripts are disabled

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

x86_64
Linux
Points:
---

Details

(URL)

(Reporter)

Description

5 years ago
STR:
 1. Disable JavaScript.
     (via NoScript, or Preferences, Content, & untick 'Enable Javascript')
 2. Visit https://marketplace.firefox.com/privacy-policy

ACTUAL RESULTS: A marketplace icon and a throbber, forever. No text appears.

EXPECTED RESULTS: The privacy policy should be displayed.
...or if it really can't be displayed without scripting, then we should display an error message telling the user that they need to enable scripts.

Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20130606 Firefox/24.0
(Reporter)

Comment 1

5 years ago
This is perhaps a special case of the fact that https://marketplace.firefox.com/ doesn't load if scripts are disabled. (It shows the same ACTUAL RESULTS - just an icon and a throbber.)  

This instance was particularly odd, though, because I'd expect that a privacy policy should be simple enough to render without scripts.
(Reporter)

Comment 2

5 years ago
Notably https://marketplace.firefox.com/developers/ loads just fine without scripts, so the whole domain isn't affected.

https://marketplace.firefox.com/terms-of-use (another basically-just-text why-would-it-need-scripting page) *is* affected, though.
Summary: [Marketplace] Marketplace Privacy Policy never finishes loading if scripts are disabled → [Marketplace] Marketplace Privacy Policy and Terms of Use pages never finish loading if scripts are disabled

Comment 3

5 years ago
The Marketplace requires JavaScript.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Comment 4

5 years ago
cvan is working on a <noscript> tag
You need to log in before you can comment on or make changes to this bug.