refactor "make details" bar to prevent CSS clobbering

RESOLVED FIXED

Status

--
blocker
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: pomax, Assigned: kate)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
we need to refactor the "make details" bar on published pages so that it lives in its own iframe, rather than details in an iframe, make details bar on the page
(Reporter)

Comment 1

6 years ago
first steps: making a absolute bar with top/left/right:0, to at least make body padding not affect our bar.
Assignee: nobody → kate
Severity: normal → blocker
Status: NEW → ASSIGNED
Duplicate of this bug: 883411
Blocks: 883419
(Assignee)

Comment 3

6 years ago
Created attachment 762993 [details]
https://github.com/mozilla/thimble.webmaker.org/pull/130/files

I also added a few things for mobile, but noticed that we need to set the right device-width meta-tag.
Attachment #762993 - Flags: review?(pomax)
(Reporter)

Comment 4

6 years ago
Comment on attachment 762993 [details]
https://github.com/mozilla/thimble.webmaker.org/pull/130/files

certainly good enough for now.
Attachment #762993 - Flags: review?(pomax) → review+
(Assignee)

Comment 5

6 years ago
https://github.com/mozilla/thimble.webmaker.org/commit/86581de6ee9b64f7fcabfdf44ded6d5e4d457e4f
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.