Use network cellIDs and nearby wifi hotspots to improve geolocation

RESOLVED DUPLICATE of bug 837987

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 837987
4 years ago
4 years ago

People

(Reporter: Elad Alfassa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130516142033

Steps to reproduce:

Right now, the only geolocation source which FirefoxOS seems to use is GPS. GPS might be very accurate, but it doesn't work well in crowded urban areas, inside buildings, or underground.

Android bypasses this problem by using google location services, which sends Google a list of nearby network cellIDs, and wifi hotspot ESSIDs from hotspots that are in range, in addition to coordinates from GPS, if known. Using this method, google has built a very large and fairly accurate database that allows them to estimate the user location quickly (although less accurately) until a GPS lock is achieved.

Firefox on Desktop uses this google service, but FirefoxOS does not.
In my opinion, we shouldn't use Google's service, and instead build our own. it will not be very accurate at start, but it will grow more accurate as we collect more data. Having a mozilla-supported geolocation service is a huge benefit, because it will protect user privacy (we won't save user identifying information like Google does).

If you choose not to implement such service, then FirefoxOS should at least be able to use the Google geolocation service (but it should be optional, as many people wouldn't like to be tracked by Google).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 837987
You need to log in before you can comment on or make changes to this bug.