Closed Bug 883389 Opened 10 years ago Closed 10 years ago

Sometimes, a blank page loads instead of the bango purchase screen due to bango API 500ing

Categories

(Marketplace Graveyard :: Payments/Refunds, defect, P1)

Other
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED
2013-06-20

People

(Reporter: krupa.mozbugs, Assigned: kumar)

References

Details

Attachments

(2 files)

Attached file http headers
Language: Spanish
Country:
Build: 1.01 

steps to reproduce:
1. From marketplace-dev, start the purchase of an app with pricetier = 2.79 euros
2. Sign in using persona
3. Enter PIN and click continue

expected behavior:
bango purchase screen loads

actual behavior:
blank screen loads

Looks like the bango payment API is 500'ing
Can't see any 500s recorded at the time, but if you look at the attachment you'll notice that request duration leapt to 10+ seconds - I wonder if this prompted a timeout?
Our proxy returned a 500 (my mistake) so I'm trying to track down the actual error that happened while talking to the Bango API here: https://github.com/mozilla/solitude/blob/master/lib/proxy/views.py#L61n I'm having a hard time finding the logs (bug 884058)
Assignee: keir → kumar.mcmillan
Target Milestone: --- → 2013-06-20
I'm going to take a crazy guess and say we exceeded our 10 second timeout ;) This should fix it https://github.com/mozilla/solitude/commit/779926f0090818e7c87e6835bfa36ef1809e389d (increases timeout to 30 secs)
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Kumar : how can I test this one in order to be sure that the 30 secs timeout will not be reached?
Flags: needinfo?(kumar.mcmillan)
there isn't really a way to do it. The API was taking 10 secs to respond, now we can handle that case. You could just verify that this price point works now, I suppose.
Flags: needinfo?(kumar.mcmillan)
You need to log in before you can comment on or make changes to this bug.