Milestones 6 & 7: Apprunner and viewer crash on startup

VERIFIED WORKSFORME

Status

P3
blocker
VERIFIED WORKSFORME
20 years ago
14 years ago

People

(Reporter: rob.coles, Assigned: don)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
My Config:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Windows NT Version 4
Service Pack 3

From System Properties
Microsoft Windows NT
4.00.1381
IE 4.0.4.72.3110.8

Computer:
x86 Family 6 Model 7 Stepping 2
AT/AT COMPATIBLE
130,484KB
What Happens:::::::::::::::::::::::::::::::::::::::::::::::::::::
When I run apprunner.exe or viewer.exe from Milestone 6 or 7 the application
crashes, Milestone 5 worked.
Dr Watson dialog box comes up and says Exception access violation (0xc0000005),
Address: 0503371b0.

For Milestone 7 -
I remove all the files from the previos installation..
Install
Run apprunner a cmd box pops up in it the text
--
width was not set
height was not set
loading url resoure:/res/profile/cpw.xul in WEBshell 4f2630

-- appears
A outline of the browser window appears
Dr Watson dialog box comes up and says Exception access violation (0xc0000005),
Address: 0503371b0.
The other windows close..

viewer behaves in a similar manner.. except that it also the number after
WEBshell is different and it
also goes on to say loading file afterwards..

Hope this is useful..
Best Wishes
Rob

Updated

20 years ago
QA Contact: leger → paulmac

Comment 1

20 years ago
paulmac - please check this with NT. And please add Talkback data here for don
sould you get the crash.  Thanks!

Comment 2

20 years ago
Rob, a couple things. First try deleting the file mozregistry.dat in your
c:\winnt directory. That file could have got corrupted in early builds. Second,
if you have Netscape Communicator installed, try renaming the Plugins directory
to something like PluginsBak and then run apprunner.
If neither of those things fix your crash, please run the build located at
ftp://ftp.mozilla.org/pub/mozilla/releases/m7/mozilla-win32-M7.zip which will
send stack trace data in to a Netscape Server when you crash. Be sure to put in
your e-mail address when prompted so we can find your crash. Thanks!

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WORKSFORME

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 3

20 years ago
rob...we cannot reproduce this.  Try what paulmac suggest and reopen if you
still have a problem.

Comment 4

20 years ago
apologies, the link for the talkback enabled build is
ftp://ftp.mozilla.org/pub/mozilla/releases/m7/mozilla-win32-M7-fullcircle.zip

Comment 5

20 years ago
Rob has debugged the problem and determined it to be related to his plug-ins.
Excellent sleuthing. Could you please determine which plugin is causing the
problem and open a new bug against the Plugins component? That would help us out
a great deal. Any questions please let us know.

To determine which plugin is causing the problem, you need to change the
extension of each plug-in in your communicatior\plugins directory one-by-one
until the crash stops. For example, npswf32.dll would be changed to
npswf32.dllbak, and then you would launch apprunner, and see if the crash still
occurs, and so on. Once you open the new bug, could you please make a comment in
this bug noting the # of the new bug?

Per your question on e-mail, you should try to do all correspondence in the bug
reports so we can keep a good history of the bug. Thanks!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.