Enable publishing with project title in URL

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: jon, Assigned: thecount)

Tracking

Details

(Whiteboard: s=2013w28)

(Reporter)

Description

5 years ago
Due to lack of time, publishing has only been enabled with short URLs: https://jon.makes.org/popcorn/asdf

We should be able to use the project title to publish to https://jon.makes.org/popcorn/something-awesome .
(Assignee)

Updated

5 years ago
Assignee: nobody → scott

Updated

5 years ago
Duplicate of this bug: 887570

Comment 2

5 years ago
Is there a technical architectural reason why we need to have /popcorn or /thimble preceding the publish URLs?

If not, it's my humble opinion that it would be a significant improvement to not have them.

The reason being that when I verbalize to a friend to check out jake.makes.org/panda it's something that they can remember. If I have to verbalize jake.makes.org/popcorn/panda it's that one extra word that's going to make the difference between remembering and not remembering.

I think there's a lot of great branding that can be done with name.makes.org/title and helps prove our theory that the open web is still wild and there's still great addresses out there.
(Reporter)

Comment 3

5 years ago
Yeah, it's something that we want to fix for sure. I'll file another bug to implement that.
Status: NEW → ASSIGNED
Whiteboard: s=2013w25 → s=2013w28
Blocks: 898427
After some discussion, the platform considerations of doing this are actually quite high. Marking as wontfix
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.