Images disappear when obscured by "popup"

RESOLVED WORKSFORME

Status

()

Core
Graphics: Layers
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: mtr, Unassigned)

Tracking

21 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 763095 [details]
screens.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

1. I have a page with few small images (buildings that can be seen on screen_1.png). 
2. I obscure them with popup window - div added to root of document that have higher z-index then content and glass screen underneath. Glass screen is full screen size, white div with 50% opacity.
3. Close popup window (remove div from document tree - screen_2.png).




Actual results:

After hiding popup window with glass screen my background images are invisible (screen_3.png) until I move mouse cursor over them.

This happens only if "glass screen" (milky screen under popup) has opacity lower then 1.

This bug can be reproduced on FF15 to FF21 (earlier versions of Fire Fox are free of that problem)


Expected results:

Images should stay visible. 

Presumably some optimization algorithm removes images from memory after obscuring them with glass screen popup window and do not load them when popup window with glass screen are removed from document tree.

Workaround: set opacity of popup window (div that lays on glass screen) to 0.999 (any value lower then 1)
(Reporter)

Comment 1

5 years ago
Created attachment 763096 [details]
screen_1.png
(Reporter)

Updated

5 years ago
Attachment #763096 - Attachment description: Screen with small images → screen_1.png
(Reporter)

Comment 2

5 years ago
Created attachment 763097 [details]
screen_2.png
(Reporter)

Comment 3

5 years ago
Created attachment 763098 [details]
screen_3.png
Hi, a testcase would be really helpful, if you can provide some link (maybe to your game if it's published).

However, does it happen also in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode) and with a clean profile (https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles)?
Component: Untriaged → Graphics: Layers
Flags: needinfo?(mtr)
Keywords: testcase-wanted
Product: Firefox → Core
(Reporter)

Comment 5

5 years ago
Game is published but still in early per-alpha stage so access is limited. I'll try to create test account for you. Unfortunately it can't be done before start of next test run (it is planned for end of July).

1. Safe mode - Problem does NOT appear in safe mod. However I tried to manually disable all my add-ons (I use only few) and the problem occurs. All my game testers reported that problem on FF and it's highly unlikely we share same add-ons.

2. Launching FF with a clean profile does not change anything. Problem still occurs.
Flags: needinfo?(mtr)
(Reporter)

Comment 6

5 years ago
Test case page: http://www.project-ark.net/index.view#COLONIES
User: daim_test
Pass: test

Test view: COLONIES

Steps to reproduce: 
1. Click on production icon (gearwheel icon with number under underneath), production window should appear.
2. Close window with "x" icon in top right corner (or click somewhere outside the popup window)
3. Most buildings images on colony view will disappear, move mouse cursor over them to "make them visible" again. 

This is closed pre-alfa test environment, this account has only temporary access (probably few weeks).
(Reporter)

Updated

5 years ago
(Reporter)

Comment 7

5 years ago
This bug appears also on Firefox 22.0
Can you still reproduce this bug?
Flags: needinfo?(mtr)
(Reporter)

Comment 9

2 years ago
No, I can not reproduce it any more but currently I have pretty old Firefox 24.8.1 ESR (I stick with that version because it's the last version that support GWT dev plugin) 

Is it possible to install two different versions of Firefox on one machine ? If yes I could install and test it on latest FF version.
Flags: needinfo?(mtr)
(In reply to mtr from comment #9)
> No, I can not reproduce it any more but currently I have pretty old Firefox
> 24.8.1 ESR (I stick with that version because it's the last version that
> support GWT dev plugin) 

Thanks, closing the bug report based on this.

> Is it possible to install two different versions of Firefox on one machine ?
> If yes I could install and test it on latest FF version.

Yes, simply install it to a separate folder and run Firefox with -P -no-remote.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Keywords: testcase-wanted
(Reporter)

Comment 11

2 years ago
Works fine on latest ESR release (38.4.0) Thx!
You need to log in before you can comment on or make changes to this bug.