Intermittent TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/content-tabs/test-plugin-blocked.js | test-plugin-blocked.js::test_blocklisted_plugin_notification

RESOLVED FIXED in Thunderbird 24.0

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: aceman, Assigned: aceman)

Tracking

({intermittent-failure})

Trunk
Thunderbird 24.0
intermittent-failure
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

7.68 KB, patch
standard8
: review+
Details | Diff | Splinter Review
(Assignee)

Description

5 years ago
SUMMARY-UNEXPECTED-FAIL | test-plugin-blocked.js | test-plugin-blocked.js::test_blocklisted_plugin_notification
  EXCEPTION: Timeout waiting for alert
    at: utils.js line 447
       TimeoutError utils.js 447
       waitFor utils.js 485
       MozMillController.prototype.waitFor controller.js 685
       NotificationWatcher.waitForNotification test-content-tab-helpers.js 135
       test_blocklisted_plugin_notification test-plugin-blocked.js 77
       Runner.prototype.wrapper frame.js 582
       Runner.prototype._runTestModule frame.js 652
       Runner.prototype.runTestModule frame.js 698
       Runner.prototype.runTestFile frame.js 531
       runTestFile frame.js 710
       Bridge.prototype._execFunction server.js 179
       Bridge.prototype.execFunction server.js 183
SUMMARY-PASS | test-plugin-blocked.js::teardownModule

This seems to be caused by Core bug 880675 where .blocklisted attribute changed to readonly so it does not have any effect in the test.
(Assignee)

Comment 1

5 years ago
Created attachment 763130 [details] [diff] [review]
patch

I updated the patch in the way Firefox tests were done in bug 880675.
I do not like I have to wait on the async callback finish via the 'testDone' variable. But I haven't found a better way yet.
Attachment #763130 - Flags: review?(mconley)
Attachment #763130 - Flags: review?(mbanner)
(Assignee)

Comment 2

5 years ago
Created attachment 763142 [details] [diff] [review]
patch v2

Sorry, this one is better.
Attachment #763130 - Attachment is obsolete: true
Attachment #763130 - Flags: review?(mconley)
Attachment #763130 - Flags: review?(mbanner)
Attachment #763142 - Flags: review?(mconley)
Attachment #763142 - Flags: review?(mbanner)
Attachment #763142 - Flags: review?(mconley)
Attachment #763142 - Flags: review?(mbanner)
Attachment #763142 - Flags: review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/6fe31acd7594
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite+
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 24.0
Comment hidden (Treeherder Robot)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Permanent orange: TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/content-tabs/test-plugin-blocked.js | test-plugin-blocked.js::test_blocklisted_plugin_notification → Intermittent TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/content-tabs/test-plugin-blocked.js | test-plugin-blocked.js::test_blocklisted_plugin_notification
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
I think this orange has been fixed by the patch for bug 933633.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 14

4 years ago
It does not happen in current tree so let's try to close this for now.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.