If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Settings] Settings interface for SIM PIN unusable due to UI misplacement

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gerard, Assigned: gduan)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 unaffected, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd unaffected, b2g-v1.2 affected)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
On current gaia master, the interface to enable/disable a SIM PIN code in Settings is broken, the vast majority of the UI is hidden on the left.
(Reporter)

Comment 1

4 years ago
Created attachment 763145 [details]
Screenshot of the description screen: okay
(Reporter)

Comment 2

4 years ago
Created attachment 763146 [details]
Screenshot of the UI for setting PIN code: not okay

Please find attached a first screenshot demonstrating the issue, just after tapping "Enable SIM PIN".
(Reporter)

Comment 3

4 years ago
Created attachment 763147 [details]
Screenshot of the UI for setting PIN code after tapping some chars: still not okay

Please find attached a second screenshot demonstrating the issue, after tapping a PIN code. You can notice that the UI moved to the right.
(Reporter)

Comment 4

4 years ago
I'm reproducing this with gecko master.
(In reply to Alexandre LISSY :gerard-majax from comment #4)
> I'm reproducing this with gecko master.

Do you mean that it works with the b2g18 branch, but not with the moz-central one?
(Reporter)

Comment 6

4 years ago
(In reply to Fabien Cazenave [:kaze] from comment #5)
> (In reply to Alexandre LISSY :gerard-majax from comment #4)
> > I'm reproducing this with gecko master.
> 
> Do you mean that it works with the b2g18 branch, but not with the
> moz-central one?

Yes. My Nexus S runs gaia master on top of b2g18 and it does not exposes the issue. The Inari was running on gecko master and it exposed the issue.
(Reporter)

Updated

4 years ago
status-b2g18: --- → unaffected
status-b2g18-v1.0.0: --- → ?
status-b2g18-v1.0.1: --- → ?
status-b2g-v1.1hd: --- → ?
status-firefox24: --- → affected

Updated

4 years ago
status-b2g18-v1.0.0: ? → wontfix
status-b2g18-v1.0.1: ? → wontfix
status-b2g-v1.1hd: ? → unaffected
Looks like 1.1 is unaffected, leo-.
blocking-b2g: leo? → -

Comment 8

4 years ago
I am seeing the same issue with a build based off Moz central.
blocking-b2g: - → koi?

Comment 9

4 years ago
Sorry forgot to mention that this issue would need to be fixed for upcoming 1.2 release and hence a request for koi?

Comment 10

4 years ago
He Fabian, is there an update on this issue?
Flags: needinfo?(kaze)
Duplicate of this bug: 904828
Hi Anshul, this is still hitting us with:
 • Gecko moz-central 20130826000531
 • Gaia master 5de91890 (= today’s version)

I’m busy with FDN stuff right now; Arthur, would you mind having a look or assigning it to someone?
Flags: needinfo?(kaze) → needinfo?(arthur.chen)
George will help on this issue. Thanks George!
Assignee: nobody → gduan
Flags: needinfo?(arthur.chen)
Created attachment 799940 [details]
PR to master

This patch will focus on input only after panel ready.
Attachment #799940 - Flags: review?(achen)
Comment on attachment 799940 [details]
PR to master

Thanks for taking care of this. Good job! r=me.
Attachment #799940 - Flags: review?(achen) → review+
Attachment #799940 - Flags: review+ → review?(arthur.chen)
Attachment #799940 - Flags: review?(arthur.chen) → review+
Thanks Arthur.

Merge into master,
https://github.com/mozilla-b2g/gaia/commit/a23ea9dfa5345d5a7cee8bc7c57df6b60d22a09d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Nice catch, thanks!

However, the SIM PIN input dialog now opens backwards. Is that a known issue? If not, would you please open a follow-up and have a look?
Flags: needinfo?(gduan)
Forget that: the dialog opens backwards because I attached a class name on the <section> container — so that’s another bug.
Flags: needinfo?(gduan)
Reopen the bug as the reproduce rate decreases but still not fixed completely.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
As the patch provided by George addresses, the root cause is that gecko tries to move the input into the viewport when the input gets focused. We must set focus after the transition completely ends or we see this bug. Apparently 'transitionend' is not sufficient in this case.
I am trying to find a way to reproduce it, but it's not so easy on latest mc 0925 build and latest gaia. Is there any suggestion?
Functional issue, blocking. Should be fixed if it can be reliable reproduced.
blocking-b2g: koi? → koi+
status-b2g-v1.2: --- → affected
status-firefox24: affected → ---
This should be in 1.2 as it landed on master on 9/5 per comment 16.

John,

Can you please check if this patch is in 1.2? If not, we can re-nom the same.
blocking-b2g: koi+ → koi?
Flags: needinfo?(jhford)
Right. Unset koi?.

Arthur, per comment 19, please open another bug if the patch is not exhaust. We don't reopen a bug with landed patch without backing the code out.
Status: REOPENED → RESOLVED
blocking-b2g: koi? → ---
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(arthur.chen)
Resolution: --- → FIXED
Let's file another bug if the issue can be reproduced.
Flags: needinfo?(arthur.chen)
Flags: needinfo?(jhford)

Updated

4 years ago
Depends on: 942993

Updated

4 years ago
No longer depends on: 942993
You need to log in before you can comment on or make changes to this bug.