If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Reduce redundant spewage from bind

RESOLVED FIXED in mozilla24

Status

()

Core
JavaScript Engine
--
enhancement
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: sunfish, Unassigned)

Tracking

Trunk
mozilla24
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
When patching all uses of a label, call masm.label() once instead of once for each use, since it produces spew output.
(Reporter)

Comment 1

4 years ago
Created attachment 763158 [details] [diff] [review]
a proposed fix
Attachment #763158 - Flags: review?(mrosenberg)
Attachment #763158 - Flags: review?(mrosenberg) → review+
(Reporter)

Comment 2

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/95d757b44adc
https://hg.mozilla.org/mozilla-central/rev/95d757b44adc
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
You need to log in before you can comment on or make changes to this bug.