If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Phantom Deleted folder created on IMAP server on Thunderbird startup

RESOLVED INCOMPLETE

Status

MailNews Core
Networking: IMAP
--
major
RESOLVED INCOMPLETE
4 years ago
2 years ago

People

(Reporter: Derek Williams, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(12 attachments)

(Reporter)

Description

4 years ago
Created attachment 763179 [details]
Screen Shot 2013-06-16 at 02.15.01.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130612084701

Steps to reproduce:

I started up Thunderbird, and found in the IMAP server, a mysterious "Deleted" folder had appeared.  The Deleted folder selected is the default as shown in the screenshot, with the icon of a Trash can, and when I delete a message in Thunderbird, that is the folder it ends up in.  When I check in Squirrel, the Trash folder also contains the trash.  When I delete it from either, it disappears correctly from the other.


Actual results:

ANOTHER Deleted folder keeps appearing.  I can delete it using File Delete Folder, whereupon it goes into the proper Deleted folder, and when I Empty Deleted, the duplicate folder disappers in both IMAP and Webmail views.  The folder remains deleted right up until I Quit Thunderbird.  When I relaunch Thunderbird, however, this Deleted folder is right back.  If I delete the folder in Squirrel, it remains deleted in Squirrel, but is still present in Thunderbird, however if I try then to Delete FOlder in Thunderbird, an error says the folder before my very eyes does not exist!


Expected results:

In view of the fact that the Deleted folder is the same in both Squirrel and Thunderbird, and that trash is going into it by default in both applications, the duplicate Deleted folder should not be there, and it certainly should not be reappearing after it has been deleted.
(Reporter)

Comment 1

4 years ago
Created attachment 763181 [details]
Delete the superflous Deleted folder
(Reporter)

Comment 2

4 years ago
Created attachment 763182 [details]
Superfluous folder gone after deletion and empty Deleted
(Reporter)

Comment 3

4 years ago
Created attachment 763183 [details]
relaunch Thunderbird and Deleted folder is back

Delete the duplicate in Squirrel, and then note that it is still present in Thunderbird.
(Reporter)

Comment 4

4 years ago
Created attachment 763184 [details]
are you sure you want to delete the folder Deleted?

this appears regardless of whether the duplicate Deleted folder is actually there or not, even though it is visible at all times.
(Reporter)

Comment 5

4 years ago
Created attachment 763185 [details]
Error message saying the duplicate Deleted folder is non-existent

This occurs if the duplicate Deleted folder created by Thunderbird is deleted in another application such as Squirrel, or RoundCube or Horde email client, running on Firefox 22 or Safari 6.0.5 on Mac 10.7.5 or Windows 7 SP2
(Reporter)

Updated

4 years ago
Severity: normal → major
(In reply to Derek Williams from comment #0)
> Created attachment 763179 [details]
> Screen Shot 2013-06-16 at 02.15.01.png

If trash folder setting is defaulted by Tb upon account creation, "Trash"(or localized name of "Trash" if localized Tb) should be shown at "Server Settings" panel.

Did you select "Inbox->Deleted" via folder selection UI of Server Settings?
If yes, dup of bug 491424?
(Reporter)

Comment 7

4 years ago
In Screenshot 1 above, you can see Server Settings for the Trash is set to the default (the one with the icon). Both folders are called 'Deleted', so although similar, I am not sure this is a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=491424, which I see has been recognised as a bug.

It may be however that the resolution to that bug will also fix mine.
(In reply to Derek Williams from comment #7)
> In Screenshot 1 above, you can see Server Settings for the Trash is set to the default (the one with the icon). 
> Both folders are called 'Deleted', (snip)

Whose "default" do you call by "Trash is set to default"?

I called "folder name which Tb tries to use as trash folder when mail.server.serverN.trash_folder_name is not set" by "Tb's default".

Was mail.server.serverN.trash_folder_name=Inbox/Deleted set by Tb since initial of account defintion in Tb?
Or it was after you selected the Inbox->Deleted as trash folder via Tb's UI?

namespace is shown at Server Settngs/Advanvced. What amespace does your IMAP server use?

> It may be however that the resolution to that bug will also fix mine.

What do you call by "resolution to that"?
manual setting to 
mail.server.serverN.trash_folder_name=Deleted?
(Reporter)

Comment 9

4 years ago
> Whose "default" do you call by "Trash is set to default"?

The Trash folder 'Deleted' automatically generated by Thunderbird when the account connects to IMAP. This folder appears in Horde and Squirrel, and any trash put into it in Thunderbird appears there in Horde and Squirrel, and any trash put into it appears correspondingly in Thunderbird.  When the Deleted folder is emptied in any of the three (Thunderbird, Squirrel or Horde), all three folders empty.  The extra 'Deleted' folder just appears and sits there. If it is deleted, and the Deleted folder described above is emptied and Compacted, the phantom Deleted folder disappears in all three environments and stays deleted in all three environments until Thunderbird is Quit. On relaunch, the phantom Deleted folder returns. After that, it again appears also in Squirrel and Horde.  If I do not use Thunderbird at all, and use only Squirrel or Horde as web browsers, the phantom Deleted folder does not appear.  Only when I launch Thunderbird does the phantom Deleted folder reappear.  The above sequence of actions is 100% reproducible.

If you like, I can make a Screen Recording of the behaviour. 
> 
> I called "folder name which Tb tries to use as trash folder when
> mail.server.serverN.trash_folder_name is not set" by "Tb's default".
> 
> Was mail.server.serverN.trash_folder_name=Inbox/Deleted set by Tb since
> initial of account defintion in Tb?

Yes - as soon as it connected to IMAP and added the Subscribed folders automatically.

it was after you selected the Inbox->Deleted as trash folder via Tb's UI?

This was already selected by Thunderbird as default, but even after reselecting as per the screenshot in position 1 above the phantom Deleted folder continues to reappear on launch of Thunderbird.
> 
> namespace is shown at Server Settngs/Advanvced. What amespace does your IMAP
> server use?

I will attach another screenshot right after this showing the Advanced Server Settings.  I don't really understand what they all mean.
> 
> > It may be however that the resolution to that bug will also fix mine.
> 
> What do you call by "resolution to that"?
> manual setting to 
> mail.server.serverN.trash_folder_name=Deleted?

Resolution to the phantom duplicate 'Deleted' folder.
(Reporter)

Comment 10

4 years ago
Created attachment 763919 [details]
Server Settings > Advanced, described in last response.
(In reply to Derek Williams from comment #9)
> I don't really understand what they all mean.
(In reply to Derek Williams from comment #10)
> Created attachment 763919 [details]
> Server Settings > Advanced, described in last response.

What is reason to kill "Allow server to override...", which is checked by default, even though you don't understand setting well?
You removed "personal namespace" and unckecked "Allow ..." in order to bypass that bug?
What is your current mail.server.serverN.trash_folder_name setting?
(Reporter)

Comment 12

4 years ago
(In reply to WADA from comment #11)
> (In reply to Derek Williams from comment #9)
> > I don't really understand what they all mean.
> (In reply to Derek Williams from comment #10)
> > Created attachment 763919 [details]
> > Server Settings > Advanced, described in last response.
> 
> What is reason to kill "Allow server to override...", which is checked by
> default, even though you don't understand setting well?

It may be I was experimenting with settings to see if I could dissuade the duplicate Deleted folder from appearing. It's all a bit of a blur now, I tried so many things really.  Normally though, if I change something and it doesn't have the desired effect, I change it back so as not to compound the trouble shooting with unretraceable steps.

> You removed "personal namespace" and unckecked "Allow ..." in order to
> bypass that bug?

Possibly, but as I said, I would normally change back if the bug were still there.

> What is your current mail.server.serverN.trash_folder_name setting?

Sorry I don't know where to look for that. Can you elucidate?
It's prefs.js setting, so you can see it by viewing prefs.js file by Text Editor. However, if value is reset or internal default is used, it's not written in prefs.js file.
Check via Config Editor. (Tools/Options/Advanced/General, Config Editor)
Relevant settings.
  mail.server.serverN.delete_model
  mail.server.serverN.trash_folder_name
  mail.server.serverN.namespace.personal
  mail.server.serverN.override_namespaces
(Reporter)

Comment 14

4 years ago
(In reply to WADA from comment #13)
> It's prefs.js setting, so you can see it by viewing prefs.js file by Text
> Editor. However, if value is reset or internal default is used, it's not
> written in prefs.js file.
> Check via Config Editor. (Tools/Options/Advanced/General, Config Editor)
> Relevant settings.
>   mail.server.serverN.delete_model
>   mail.server.serverN.trash_folder_name
>   mail.server.serverN.namespace.personal
>   mail.server.serverN.override_namespaces


I am attaching a series of screenshots right after this showing all the above values.  FYI, on Mac version, the Config Editor is in Preferences (screenshot attached), not Options.
(Reporter)

Comment 15

4 years ago
Created attachment 763950 [details]
Config editor in Mac located in Preferences
(Reporter)

Comment 16

4 years ago
Created attachment 763951 [details]
delete_model
(Reporter)

Comment 17

4 years ago
Created attachment 763952 [details]
trash_folder_name
(Reporter)

Comment 18

4 years ago
Created attachment 763953 [details]
namespace.personal (3 settings)
(Reporter)

Comment 19

4 years ago
Created attachment 763954 [details]
override_namespaces (2 settings)
"Confg Editor" has "Copy" feature. Use "Copy ..." of context menu of each entry listed in "Config Editor", for readability of bug by developers and QA peoples, please.
(Reporter)

Comment 21

4 years ago
(In reply to WADA from comment #20)
> "Confg Editor" has "Copy" feature. Use "Copy ..." of context menu of each
> entry listed in "Config Editor", for readability of bug by developers and QA
> peoples, please.


mail.server.default.delete_model;1
mail.server.server9.trash_folder_name;INBOX/Deleted
mail.server.server10.namespace.personal;"INBOX."
mail.server.server7.namespace.personal;""
mail.server.server8.namespace.personal;""
mail.server.default.override_namespaces;true
mail.server.server9.override_namespaces;false
Problem on which server/account?

Because "Deleted under INBOX" is seen in screen shot, we can guess that server9 is relevant account/server. But problem analysis and bug fixing based on guess is not acceptable at bugzilla.mozilla.org, even if such "work based on guess" is normal and usual action in your company or country.

  mail.accountmanager.accounts = ...
  => mail.account.accountN.identities = idA1, ... , iAm
     mail.account.accountn.server     = serverX
  => mail.server.serverX.type = imap, pop3, nntp, none, rss, ...
     mail.server.serverX.xxx
          where xxx = property of mail.server.serverX
(Reporter)

Comment 23

4 years ago
Even if I am useless I don't think it fair to generalise that the entire United Kingdom is as hopeless as me.  I am sure am the dumbest by far.

I am just an ordinary unintelligent user of low competence.

Sorry I can't help further.
(Reporter)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Comment 24

4 years ago
Please don't mess with the resolution.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WONTFIX → ---

Updated

4 years ago
Status: REOPENED → UNCONFIRMED
Ever confirmed: false

Updated

2 years ago
Component: Untriaged → Networking: IMAP
Product: Thunderbird → MailNews Core

Comment 25

2 years ago
(In reply to Derek Williams from comment #23)
> ...
> Sorry I can't help further.

The circumstances of this won't get any clearer, so => incomplete
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago2 years ago
Resolution: --- → INCOMPLETE
Summary: Phantom Deleted folder created on IMAP server → Phantom Deleted folder created on IMAP server on Thunderbird startup
You need to log in before you can comment on or make changes to this bug.