GLSL in WebGL (three.js) does not appear to support loops

RESOLVED WORKSFORME

Status

()

Core
Canvas: WebGL
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Eric Haines, Unassigned)

Tracking

21 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36

Steps to reproduce:

I used a loop in a GLSL fragment shader program, using WebGL (through three.js). The results can be seen here: http://www.realtimerendering.com/udacity/unit9/anisotropic-material_sol/index.html - this program works fine on Chrome, it fails on Firefox.


Actual results:

http://i.imgur.com/uUoKY2l.jpg is what is seen on the screen.


Expected results:

http://i.imgur.com/o2V0dq3.jpg is what should be seen, and what is seen on Google Chrome.

The problem is the loop in the GLSL fragment shader. If this loop is unrolled, Firefox works fine and gives the same image as Chrome.

The code is a part of https://github.com/udacity/cs291, in https://github.com/udacity/cs291/tree/master/unit9/anisotropic-material
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core

Comment 1

5 years ago
Broken in FF21, fixed in FF24, so the issue is already fixed in higher versions. Could you confirm on your side?
http://nightly.mozilla.org/
Flags: needinfo?(erich)
(Reporter)

Comment 2

5 years ago
Confirmed! The nightly fixes this, http://www.realtimerendering.com/udacity/unit9/anisotropic-material_sol/index.html runs fine. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(erich)
Resolution: --- → WORKSFORME

Comment 3

5 years ago
For the record, working range:
bad=2013-05-16
good=2013-05-17
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cc139752bed4&tochange=ea767da526ff

Maybe a dupe of bug 872701.
You need to log in before you can comment on or make changes to this bug.