link preview gives different results even for the same link

RESOLVED DUPLICATE of bug 731106

Status

()

RESOLVED DUPLICATE of bug 731106
6 years ago
6 years ago

People

(Reporter: jidanni, Unassigned)

Tracking

23 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130614 Firefox/23.0 Iceweasel/23.0a2 (Nightly/Aurora)
Build ID: 20130614004016

Steps to reproduce:

You won't believe this one.
Install totally fresh Firefox.
Browse http://www.facebook.com/help/213481848684090/
(no account needed.)

See the
    Mozilla Firefox
    Safari
    Google Chrome
    Internet Explorer
list?

Well slowly move the pointer over one of them whilst watching the
lower left corner of the screen for link preview.

Now do it again on the same link.


Actual results:

Notice how the results are different now, even for the same link!!



Expected results:

Yes there is a reason.

But that's no excuse!

Now since you can't make up your mind,

why don't you show the user both.

Don't play double take or switcheroo.

And please don't mention extensions. I am not asking for any functionality. I am saying you have a bug in the way you present things.

Comment 1

6 years ago
I'm not able to repro the issue on Win 7.

Comment 2

6 years ago
Ok, I see what you mean:

1st over: tooltip displays 
http://www.facebook.com/l.php?u=http://www.mozilla.com/en-US/firefox/all.html&h=9AQFYwd6p&s=1

2nd over: tooltip displays
http://www.mozilla.com/en-US/firefox/all.html

Code source:
<a href="http://www.mozilla.com/en-US/firefox/all.html" rel="nofollow" target="_blank" onmouseover="LinkshimAsyncLink.swap(this, &quot;http:\/\/www.mozilla.com\/en-US\/firefox\/all.html&quot;);" onclick="LinkshimAsyncLink.swap(this, &quot;\/l.php?u=http\u00253A\u00252F\u00252Fwww.mozilla.com\u00252Fen-US\u00252Ffirefox\u00252Fall.html&amp;h=9AQFYwd6p&amp;s=1&quot;);">Mozilla Firefox</a>
(Reporter)

Comment 3

6 years ago
Yes, and besides the security arguments which I am purposely not bringing up here, at least the program should not play eye games with the user.
(Reporter)

Comment 4

6 years ago
I.e., be consistent.

Comment 5

6 years ago
Duplicate of bug 554176 / bug 731106.
Whiteboard: DUPEME

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 731106
You need to log in before you can comment on or make changes to this bug.