All users were logged out of Bugzilla on October 13th, 2018

[clock] Alarm sounds and the music is played at the same time.

RESOLVED WONTFIX

Status

P1
normal
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: leo.bugzilla.gaia, Unassigned)

Tracking

unspecified
1.1 QE3 (26jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: [TD-45878])

(Reporter)

Description

5 years ago
1. Title : Alarm sounds and the music is played at the same time.
2. Precondition : 
3. Tester's Action :1. Set alarm
                   :2.Playing music
                   :3.After setting the alarm to play music.
                   :4.The alarm is sounding, press the Home button to   switch
                      to music tab.
4. Detailed Symptom (ENG.) : After setting the alarm to play music. The alarm           is sounding, press the Home button to switch to the Music tab.
Alarm sounds and the music is played at the same time.

6. Expected : when Alarm is ring music should not be sound.
7. Reproducibility: Y
1)Frequency Rate : 100%
(Reporter)

Updated

5 years ago
Priority: -- → P1
Whiteboard: [TD-45878]
(Reporter)

Updated

5 years ago
Target Milestone: --- → 1.1 QE3 (24jun)
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo+

Comment 1

5 years ago
Hi Leo,

I think it is under the design now because there is a rule of all foreground window can play sound no matter it's audiochannel type or any other highest priority channel there.

Can you confirm this rule or we need UX inputs here? Thanks.
cc relative devs. I'm not sure the foreground window rule is defined and noted in wiki page or not. https://wiki.mozilla.org/WebAPI/AudioChannels
I just know the rule..
Is this real a bug?
Some android device dismiss the alarm when home is pressed.
Some android device plays the music and the alarm at the same time(But alarm is really louder than music so music playing is ignored).
See comment 1, comment 3.
I'd like to ask leo? on this one because I don't this is a bug nor blocking.

The only thing we could do: close the alarm once home button is pressed to avoid the app playing audio at the same time.
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Comment 5

5 years ago
we check android behavior when Home button press then Alarm goes to snooze..
so alarm snoozed when home button is pressed.
Flags: needinfo?(leo.bugzilla.gaia)
^ Ian, would we regress something is alarm goes snooze when it gets window.resize event?
Do you means that snooze the alarm when alarm goes off and user click home button? It will receive window.resize event in attention status bar mode. I think there won't be any regress for the solution. But why do we need to implement attention status bar style. We could never see that again since always snooze it in this case. It would be better with UX's input here.
(In reply to Ian Liu [:ianliu] from comment #7)
> Do you means that snooze the alarm when alarm goes off and user click home
> button? It will receive window.resize event in attention status bar mode. I
> think there won't be any regress for the solution. But why do we need to
> implement attention status bar style. We could never see that again since
> always snooze it in this case. It would be better with UX's input here.

Yes, need UX input but would like to know if there's some problems programmatically if we decide to do this..
In case of phone call coming, the symptom is same with alarm. If we decide this is an issue and request UX's input, I propose UX should consider music vs alarm/call together.
We need UX input here to decide it an issue or not.
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 11

5 years ago
Assigning this leo+ to Casey to advise on whether or not UX input is even needed. :)
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(kyee)

Comment 12

5 years ago
This isn't really a bug, and certainly not important enough to be blocking.

As mentioned already in Comment 1, the foreground app always has the ability to make sounds regardless of channel.  This same scenario is also present when a user answers a incoming call and decides to play music/media while on the call.   

I also think that the proposal to key the snooze function while the alarm is sounding makes sense.    I wouldn't turn the alarm off though since users may end up missing their alarms (I know I would!).   Please open a separate bug for this feature.   

I'm going to mark this bug "Won't fix" since the behavior is as intended.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(kyee)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.