page [wrongly] comes up in Big5 charset

VERIFIED WORKSFORME

Status

()

Core
Internationalization
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Calum Mackay, Assigned: nhottanscp)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.1+) Gecko/20010625
BuildID:    2001062522

Everytime I visit this page, it comes up in the Chinese Big5 charset;
the page source itself has this in it:

<meta http-equiv="Content-Type" content="text/html; charset=Big5">

which might suggest that it's the site's fault but this does not
occur when I view the site with NS 4.77.

It's as though mozilla is asking the site to show the Chinese
version for some reason?



Reproducible: Always
Steps to Reproduce:
1.just visit the site.
2.
3.

Actual Results:  Page comes up in Big5 charset.

Expected Results:  Should come up in a more local charset.

I cleared both disk and memory caches, to no effect.

I've not had this problem with any other site.

Character-coding auto-detect is off.

Character-coding is set to ISO-8859-1.

Comment 1

17 years ago
-> intl people for triage
Assignee: asa → nhotta
Component: Browser-General → Internationalization
QA Contact: doronr → andreasb
(Assignee)

Comment 2

17 years ago
>Expected Results:  Should come up in a more local charset.

I don't understand, the page's META charset is Big5, what else should be expected?

Comment 3

17 years ago
Switching QA contact to ylong.
QA Contact: andreasb → ylong
(Reporter)

Comment 4

17 years ago
It just seemed rather unlikely that Debian's UK mirror would be implemented
using a Chinese Big5 charset. It does not appear this way in other browsers,
nor in Netscape 4.77.

In addition, I've also seen similar behaviour at http://www.debian.org/, the
main US page, which often - but not always - comes up in German, which again
can't be correct.

Finally, when I view the page source for http://www.uk.debian.org/ using
Netscape 4.77, I see this META tag:

<META http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

but when viewed with mozilla, I see this:

<meta http-equiv="Content-Type" content="text/html; charset=Big5">

This hasn't happened with every build of mozilla, and it doesn't happen
absolutely every time I try the site.

Given these points, I don't believe this is a bug with the Debian pages.
(Assignee)

Comment 5

17 years ago
I don't have the problem using NS6 PR1, I got Engish page.
This could be related to accept language, what is your setting?
(Reporter)

Comment 6

17 years ago
I have now reproduced the problem on a different system:

mozilla release 0.9.2
Linux x86 glibc 2.2.3

[again viewing http://www.uk.debian.org/]

In Preferences->Naviagtor->Languages, I have only one: "English/United States"
and the default character coding on the same page is set to:
"Western (ISO-8859-1)"

The page's source shows clearly that Debian is supplying us with a Chinese
page:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html lang="zh-HK">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=Big5">
<title>Debian GNU/Linux -- ?????? (The Universal Operating System)</title>
<link REV="made" HREF="mailto:webmaster@debian.org">
<meta NAME="Description" CONTENT="Debian GNU/Linux is a free distribution of the
GNU/Linux operating system. It is maintained and updated through the work of
many users who volunteer their time and effort.">
<meta NAME="Keywords" CONTENT="debian, GNU, linux, unix, open source, ????,
?????, ?????, free, ??, DFSG">
<meta NAME="Language" CONTENT="Chinese">

Since this happens with no other browser, I had wondered whether Debian
is supplying the browser with this page based upon some information
[wrongly] supplied by the browser? Is this not possible?
The other possibility is that Debian have got their mirrors all messed up,
although I would have expected someone to notice by now (I've been seeing
this for a number of weeks). In this case, I wonder why I don't have a problem
with other browsers?

I'd appreciate any assistance in tracking down exactly what's going on here.
(Reporter)

Comment 7

17 years ago
I used a test cgi script to verify:

environment: HTTP_ACCEPT_LANGUAGE = en-us 

Also, another user here has the same problem, with the same build
rv:0.9.2+) Gecko/20010701, so it seems unlikely that it's caused
by anything in my environment.

I will also run this past the Debian people for comment.

(Assignee)

Comment 8

17 years ago
Cc to momoi in case this is a server problem.
(Assignee)

Comment 9

17 years ago
I cannot reproduce this on Windows 2000 with NS6.1 PR1.
Katakai san, can you reproduce this on Solaris?
(Reporter)

Comment 10

17 years ago
OK, well I've now reproduced the problem with lynx, so there's
a problem with either my caching server, or with the Debian page itself.
Clearly it's not mozilla's fault.

Thanks for the assistance, and apologies for wasting your time.

Would someone please close this bug [or am I supposed to do that myself?]

best regards,
Calum.
(Assignee)

Comment 11

17 years ago
okay, worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 12

17 years ago
Mark as verified per comments above.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.