Closed Bug 883738 Opened 7 years ago Closed 7 years ago

[FTU] You will stuck with homekey locked when you click notification in FTU

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+)

RESOLVED FIXED
blocking-b2g koi+

People

(Reporter: wachen, Assigned: alive)

References

Details

Attachments

(1 file)

PVT BUILD Unagi 2013-06-16
Gaia:     f2d6ed54a236e6e3b94f0abad9f0dacb8a1cc7b3
  B-D     2013-06-15 07:33:44
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/15d9885034a0
BuildID   20130616070209
Version   18.0

STR:
0. flash your phone
1. don't finish the FTU
2. send a sms to FXOS phone
3. tap the notification shown

expected result:
it should still stay in FTU

actual result:
it went to Message app
PVT BUILD Unagi V1Train 2013-0811
Gaia:     c60e3507d9df160e006d2e25967d26df2dc543cb
  B-D     2013-08-11 21:53:25
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/36bbc5943448
BuildID   20130812041203
Version   18.0

This still reproduces.
The bad thing about this is that you can never go back to FTU and stay in Message app forever. (Home Key still locked)
blocking-b2g: --- → leo?
Summary: [FTU] You can skip FTU by clicking on the notification shown → [FTU] You will stuck with homekey locked when you click notification in FTU
We'd only block on this for 1.1 if this was a new regression, otherwise over to koi?
Tested this on Leo using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/15813d776a69
Gaia   dd3959fa74e356a528daa76ffee14c2c728a4b56
BuildID 20130813121736
Version 18.0

I was able to reproduce this issue once, and it happened when I had advanced to the second page on the FTU.

As Walter notes the home key won't work, but if I reboot the phone I am back in the FTU. So while it isn't a great user experience there is a still a way to get back into the FTU.
Keywords: qawanted
Note -  I think the qawanted request here was to see if this reproduces on 1.01. If it does, then it's a regression. If it doesn't, then this isn't a blocker.
(In reply to Jason Smith [:jsmith] from comment #4)
> Note -  I think the qawanted request here was to see if this reproduces on
> 1.01. If it does, then it's a regression. If it doesn't, then this isn't a
> blocker.

Said that backwards. If it does reproduce on 1.01, then it isn't a regression. If it doesn't, then it's a regression.
Most recent v1.0.1 pvt build
Gaia:     054cdc27404e2daca91d3065d9783681032b2151
  B-D     2013-07-06 19:39:29
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9c62297d11b0
BuildID   20130813043203
Version   18.0

The bug in v101 is kind of different.

STR:
0. flash your phone
1. don't finish the FTU
2. send a sms to FXOS phone
3. tap the notification shown

expected result:
it should still stay in FTU

actual result:
it went to Message app and homekey didn't get locked. However, if you use homekey to go back, the screen would be empty.
:/

My proposal would to: Disable the notification click during FTU for this case.
Assignee: nobody → alive
AFAIK this is not a regression.
Great catch, I didn't think of this way before...
(In reply to Alex Keybl [:akeybl] from comment #2)
> We'd only block on this for 1.1 if this was a new regression, otherwise over
> to koi?

Per comment 8 and above testing, over to koi.
blocking-b2g: leo? → koi?
Keywords: qawanted
Ignore notification toaster tap event when ftu is running.
Attachment #804086 - Flags: review?(timdream)
Duplicate of this bug: 903317
Attachment #804086 - Flags: review?(timdream) → review+
master
https://github.com/mozilla-b2g/gaia/commit/6daadc0648db36252fea687f1ceba1de6ad9428d
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
blocking-b2g: koi? → koi+
You need to log in before you can comment on or make changes to this bug.