[A/V] Crash occur in music application (pthread_mutex_lock | android::OmxDecoder::ReleaseMediaResources())

RESOLVED FIXED in Firefox 24, Firefox OS v1.1hd

Status

P1
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: leo.bugzilla.gecko, Assigned: sotaro)

Tracking

({crash})

unspecified
1.1 QE3 (26jun)
ARM
Gonk (Firefox OS)
crash

Firefox Tracking Flags

(blocking-b2g:leo+, firefox22 wontfix, firefox23 wontfix, firefox24 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

Details

(Whiteboard: [b2g-crash], crash signature)

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Precondition : put some music files in SD card.

STR
1. start music app
2. select icon to repeat all music
3. push next music button several times.

Then crash occur 100%.
We need two things to make this actionable:

1. The music files in question - can we get access to them?
2. A crash report ID

[2] can be found by getting the crash to happen, connecting to wifi, and waiting for the report to be submitted. Upon submission, follow the steps here - https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#Getting_crashes_off_the_Device to get your crash report ID.

Updated

5 years ago
Keywords: crash
Whiteboard: [b2g-crash]

Updated

5 years ago
Severity: major → critical
Flags: needinfo?(leo.bugzilla.gecko)
Keywords: stackwanted
(Reporter)

Comment 2

5 years ago
Created attachment 763455 [details]
dump file
Flags: needinfo?(leo.bugzilla.gecko)
(Reporter)

Comment 3

5 years ago
Created attachment 763456 [details]
extra
(Reporter)

Comment 4

5 years ago
(In reply to Jason Smith [:jsmith] from comment #1)
> We need two things to make this actionable:
> 
> 1. The music files in question - can we get access to them?
> 2. A crash report ID
> 
> [2] can be found by getting the crash to happen, connecting to wifi, and
> waiting for the report to be submitted. Upon submission, follow the steps
> here -
> https://wiki.mozilla.org/B2G/QA/
> Tips_And_Tricks#Getting_crashes_off_the_Device to get your crash report ID.

I cannot report crash. It's connected by WIFI and Crash report setting is set to "Always send a report"
However every crashes leaved in minidump directory.

I attached one.
(In reply to leo.bugzilla.gecko from comment #4)
> (In reply to Jason Smith [:jsmith] from comment #1)
> > We need two things to make this actionable:
> > 
> > 1. The music files in question - can we get access to them?
> > 2. A crash report ID
> > 
> > [2] can be found by getting the crash to happen, connecting to wifi, and
> > waiting for the report to be submitted. Upon submission, follow the steps
> > here -
> > https://wiki.mozilla.org/B2G/QA/
> > Tips_And_Tricks#Getting_crashes_off_the_Device to get your crash report ID.
> 
> I cannot report crash. It's connected by WIFI and Crash report setting is
> set to "Always send a report"
> However every crashes leaved in minidump directory.
> 
> I attached one.

I'm talking about a crash report ID. When you crash, a crash report gets queued to get sent to Socorro. After being connected to wifi, a crash report is then sent to Socorro. After the submission is successful, a crash report ID should appear in the following directory in your phone:

/data/b2g/mozilla/Crash Reports/submitted

What I'm asking for is the latest crash report ID found in this directory after the crash is submitted.
(Reporter)

Comment 6

5 years ago
Created attachment 763997 [details]
include call stack
(Reporter)

Comment 7

5 years ago
I don't know why crash report is not uploaded.
.dmp and .extra files remained in minidump directory.
They doesn't move to Crash Reports/submitted.

I upload dump file with call stack.
blocking-b2g: --- → leo?

Updated

5 years ago
Crash Signature: [@ pthread_mutex_lock | android::OmxDecoder::ReleaseMediaResources] [@ pthread_mutex_lock | android::OmxDecoder::ReleaseMediaResources()]

Updated

5 years ago
Keywords: stackwanted

Updated

5 years ago
Summary: [A/V] Crash occur in music application → [A/V] Crash occur in music application (pthread_mutex_lock | android::OmxDecoder::ReleaseMediaResources())
(Reporter)

Updated

5 years ago
Priority: -- → P1
Target Milestone: --- → 1.1 QE3 (24jun)
(Assignee)

Updated

5 years ago
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Comment 9

5 years ago
Created attachment 764201 [details] [diff] [review]
patch for b2g18 - add pointer null check

By applying the patch, I confirmed that the crash did not happen on v1.1 leo.
(Assignee)

Updated

5 years ago
Attachment #764201 - Flags: review?(chris.double)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED

Updated

5 years ago
Attachment #764201 - Flags: review?(chris.double) → review+
(Assignee)

Comment 10

5 years ago
Created attachment 764876 [details] [diff] [review]
patch v2 - add pointer null check

Add a header. Carry "chris.double: review+".
Attachment #764201 - Attachment is obsolete: true
Attachment #764876 - Flags: review+
(Assignee)

Comment 11

5 years ago
Created attachment 764879 [details] [diff] [review]
patch v2 for b2g18 - add pointer null check

Add a header. Carry "chris.double: review+".
Attachment #764879 - Flags: review+
blocking-b2g: leo? → leo+
status-b2g18: --- → affected
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/aa697ddff046
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-b2g18/rev/a43197217f97
status-b2g18: affected → fixed
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
status-b2g-v1.1hd: --- → affected
status-firefox22: --- → wontfix
status-firefox23: --- → wontfix
status-firefox24: --- → fixed
It seems that we have reproduce this crash since the fix landed on the v1.1.  Has the reporter seen the crash with the fix present?
Flags: needinfo?(leo.bugzilla.gecko)
(Reporter)

Comment 18

5 years ago
No, after the patch, I have never seen crash by same steps in comment #0.
And same call stack attachment #763997 [details], neither.
Flags: needinfo?(leo.bugzilla.gecko)
You need to log in before you can comment on or make changes to this bug.