[Dialer][Call log] Contacts number saved with prefix are not correctly managed when appear in the call log

RESOLVED DUPLICATE of bug 877956

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 877956
5 years ago
3 years ago

People

(Reporter: isabelrios, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: leorun3)

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 763426 [details]
call log

Leo device, testrun3 build:
Gaia: ea18de8

Test Case id: #2258

PROCEDURE
1. Create a contact with number and prefix: +346xxxxxxxx
2. Call to that contact
3. Now type the contact number with prefix: 00346xxxxxxxx
4. Verify the call log

EXPECTED
When dialing to 00346xxxxxxxx the name of the contact should appear.

ACTUAL
When dialing the number with 00346xxxxxxxx the number is not recognized as the contact's name
Plase see screenshot attached where Aprefi is the contacts saved with +346xxxxxxxx, and the dial to the same number with 0034 which is not recognized.
Hi Isabel,
I have just tested with latest v1-train (Gecko-c6e29ce, Gaia-3e90908) (in fact I fetched the latest Gaia code from the v1-train branch) and it works for me. See the new attachments, please. Could you please retry it in case this has already been solved? Thanks!
Flags: needinfo?(isabelrios)
Created attachment 764070 [details]
The contact
Created attachment 764071 [details]
The resulting call log
Assignee: nobody → gtorodelvalle
Not blocking s it looks like its not reproducible and may have been resolved in the latest build, feel free to renom if needed.
blocking-b2g: leo? → -

Updated

5 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Hi Isabel, would you be so kind to re-test it regarding comment 4, please? Thank you very much! ;-)
(Reporter)

Comment 6

5 years ago
Hi!

With unagi device 06/28 v1-train build:
Gecko-db60841
Gaia-508cfc8

I can still reproduce the problem. The call to a contact with +34number and the call directly to 0034number, are not grouped in the call log.
Flags: needinfo?(isabelrios)
(Reporter)

Comment 7

5 years ago
Created attachment 768977 [details]
two entries for the same number
(Reporter)

Comment 8

5 years ago
(In reply to Isabel Rios [:isabel_rios] from comment #6)
> Hi!
> 
> With unagi device 06/28 v1-train build:
> Gecko-db60841
> Gaia-508cfc8
> 
> I can still reproduce the problem. The call to a contact with +34number and
> the call directly to 0034number, are not grouped in the call log.

Sorry, the problem now is not exactly as reported, now the call to 0034number is recognized as a call to the contact, but it is not grouped with the one whitout prefix.
Leaving as unassigned since not working on it right now...
Assignee: gtorodelvalle → nobody
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 877956
You need to log in before you can comment on or make changes to this bug.