[Cost Control]Wi-Fi usage graph is increasing even wi-Fi is in OFF state.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Cost Control
P1
major
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Leo, Assigned: michalbe)

Tracking

unspecified
1.1 QE3 (26jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: [TD-46107])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
1. Title : Wi-Fi usage graph is increasing even wi-Fi is in OFF state.
2. Precondition : Usage->Settings->Reset
3. Tester's Action : 
   1. wi-fi off 
   2. Usage - wifi Toggle - check/ON
   3. browser connect
   4. Use the browser for about 5 minutes.
   5. home - Usage
4. Detailed Symptom (ENG.) : wi-fi usage is increasing and displayed.
6.Reproducibility: Y(2 out of 5 times)
1)Frequency Rate : 50%
7.Gaia Master/v1-train : Reproduced
8.Gaia Revision: 0c836be7f24693b74ad7fd21c8153824f1c7f548
9.Personal email id: vsireesha246@gmail.com
(Reporter)

Updated

5 years ago
Priority: -- → P1
Whiteboard: [TD-46107]
Target Milestone: --- → 1.1 QE3 (24jun)
(Reporter)

Comment 1

5 years ago
Created attachment 763454 [details]
Logs are attached.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo+
I can not reproduce. How much Wi-Fi usage is being reported after switching off Wi-Fi? Are you sure it is the Wi-Fi chart (the green one) which is being increased?
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Comment 3

5 years ago
Created attachment 763492 [details]
Usage screen shot attached

Hi Salva,

I attached the Usage graph screen shot.
(Reporter)

Updated

5 years ago
Flags: needinfo?(leo.bugzilla.gaia)
This can be related with bug 879770. Note this was included into the latest Gecko by June, 5th. How old is the Gecko you're trying with?
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Comment 5

5 years ago
Created attachment 763975 [details]
The logs of netcfg command is attached.
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Comment 6

5 years ago
Hi Salva,

Please find the below information.

os version 1.1.0.0-prerelease
platform version 18.0
Build identifier 20130607202028
gecko revision tag:f785614a388125557e5fb9fd567ea789476e1954
(Reporter)

Comment 7

5 years ago
Please ignore the above Gecko revision:
Please find the correct one gecko revision:b518de015ff9d28c7a59a9f1e799fc0ec688024e
(Reporter)

Comment 8

5 years ago
NetworkStatsManager: getNetworkStats: {"start":{"__date__":"2013-06-16T15:00:00.000Z"},"end":{"__date__":"2013-06-29T15:00:00.000Z"},"connectionType":"wifi"}
NetworkStatsService: receiveMessage NetworkStats:Get
NetworkStatsService: Update stats for wifi
NetworkManager: There is no interface registered for network type 0
NetworkStatsService: There is no interface registered for network type wifi
NetworkStatsService: Update stats for wifi: rx=0 tx=0 timestamp=Mon Jun 17 2013 15:19:20 GMT+0900 
NetworkStatsService: Update stats for mobile
NetworkManager: getNetworkInterfaceStats for rmnet0
Network Worker: received message: {"cmd":"getNetworkInterfaceStats","ifname":"rmnet0","connType":1,"report":true,"isAsync":true,"id":""}
Network Worker: getNetworkInterfaceStats: rmnet0
Network Worker: Preparing to send 'interface readrxcounter rmnet0' command...
Network Worker: Sending 'interface readrxcounter rmnet0' command to netd.
Network Worker: Receiving 'interface readrxcounter rmnet0' command response from netd.
Network Worker:           ==> Code: 216  Reason: 5363367
Network Worker: Preparing to send 'interface readtxcounter rmnet0' command...
Network Worker: Sending 'interface readtxcounter rmnet0' command to netd.
Network Worker: Receiving 'interface readtxcounter rmnet0' command response from netd.
Network Worker:           ==> Code: 217  Reason: 1050430
NetworkManager: NetworkManager received message from worker: {"cmd":"getNetworkInterfaceStats","ifname":"rmnet0","connType":1,"report":true,"isAsync":true,"id":"","rxBytes":5363367,"txBytes":1050430,"date":"2013-06-17T06:19:20.618Z","resultCode":217,"resultReason":"1050430\u0000"}
NetworkStatsService: Update stats for mobile: rx=1050430 tx=5363367 timestamp=Mon Jun 17 2013 15:19:20 GMT+0900 
NetworkStatsService: ===== LOG =====
NetworkStatsService: There are 17 items
NetworkStatsService: [{"connectionType":"mobile","timestamp":1370736000000,"rxBytes":133065,"txBytes":353135,"rxTotalBytes":133065,"txTotalBytes":353135},{"connectionType":"mobile","timestamp":1370822400000,"rxBytes":76124,"txBytes":443284,"rxTotalBytes":61276,"txTotalBytes":432812},{"connectionType":"mobile","timestamp":1370908800000,"rxBytes":1570276,"txBytes":348515,"rxTotalBytes":708,"txTotalBytes":612},{"connectionType":"mobile","timestamp":1370995200000,"rxBytes":96896,"txBytes":614940,"rxTotalBytes":93767,"txTotalBytes":612135},{"connectionType":"mobile","timestamp":1371081600000,"rxBytes":0,"txBytes":0,"rxTotalBytes":93767,"txTotalBytes":612135},{"connectionType":"mobile","timestamp":1371168000000,"rxBytes":0,"txBytes":0,"rxTotalBytes":93767,"txTotalBytes":612135},{"connectionType":"mobile","timestamp":1371254400000,"rxBytes":0,"txBytes":0,"rxTotalBytes":93767,"txTotalBytes":612135},{"connectionType":"mobile","timestamp":1371340800000,"rxBytes":0,"txBytes":0,"rxTotalBytes":0,"txTotalBytes":0},{"c
NetworkStatsService: getstats for: - wifi -
NetworkStatsManager: NetworkStatsmanager::receiveMessage: NetworkStats:Get:Return
NetworkStatsManager: NetworkStats Constructor
NetworkStatsManager: result: {"connectionType":"wifi","start":"2013-06-16T15:00:00.000Z","end":"2013-06-29T15:00:00.000Z","data":[{"rxBytes":88694,"txBytes":637046,"date":"2013-06-17T00:00:00.000Z"},{"date":"2013-06-18T00:00:00.000Z"},{"date":"2013-06-19T00:00:00.000Z"},{"date":"2013-06-20T00:00:00.000Z"},{"date":"2013-06-21T00:00:00.000Z"},{"date":"2013-06-22T00:00:00.000Z"},{"date":"2013-06-23T00:00:00.000Z"},{"date":"2013-06-24T00:00:00.000Z"},{"date":"2013-06-25T00:00:00.000Z"},{"date":"2013-06-26T00:00:00.000Z"},{"date":"2013-06-27T00:00:00.000Z"},{"date":"2013-06-28T00:00:00.000Z"},{"date":"2013-06-29T00:00:00.000Z"},{"date":"2013-06-30T00:00:00.000Z"}]}
NetworkStatsManager: getNetworkStats: {"start":{"__date__":"2013-06-16T15:00:00.000Z"},"end":{"__date__":"2013-06-29T15:00:00.000Z"},"connectionType":"mobile"}
NetworkStatsManager: NetworkStatsmanager::receiveMessage: NetworkStats:Get:Return
NetworkStatsService: receiveMessage NetworkStats:Get
NetworkStatsService: Update stats for wifi
NetworkManager: There is no interface registered for network type 0
NetworkStatsService: There is no interface registered for network type wifi
NetworkStatsService: Update stats for wifi: rx=0 tx=0 timestamp=Mon Jun 17 2013 15:19:20 GMT+0900 

NetworkStatsManager: result: for wifi for "rxBytes":88694,"txBytes":637046, and total=tx+rx = 725.74KB as shown in screenshot.

Here Update stats for wifi: rx=0 tx=0 then why in logs "rxBytes":88694,"txBytes":637046 is shown.

May be this wifi data is shown even in wifi OFF satate?
(Reporter)

Updated

5 years ago
Flags: needinfo?(salva)
No, this is the consumption for today but the Usage application is taking in count the amount of data at the reset moment to substract it from the total.
Flags: needinfo?(salva)

Comment 10

5 years ago
I'm able to reproduce it. When wifi is switched off some bytes are sent but it is not registered because the event of shutdown does not trigger an update of stats. The update is done when you open costcontrol.

I think this bug is the same as bug 879793, which was not flagged as leo+.

Comment 11

5 years ago
Can you confirm if it is related with bug 879793?
Flags: needinfo?(leo.bugzilla.gaia)
If yes, we recommend not blocking for 1.1 as well. This has a very minor user impact.

Updated

5 years ago
blocking-b2g: leo+ → leo?
(Reporter)

Comment 13

5 years ago
Hi Albert,

This issue is happening with Wi-Fi only and it is reproduced 2 out of 5times(Random)
Now we are not able to reproduce the same scenario.

Here costcontrol app is not closed and is in open,but the Wi-Fi is OFF and with mobile browsing is done.Along with mobile usage,Wi-Fi usage is increasing as shown in attached screenshot.

As per my understanding Bug 879793 is not updating the usage when the network is down.But in this bug usage is updating.
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Comment 14

5 years ago
Currently issue is not reproduciable(By tester and me).We can mark this issue as tracking because this issue is reproduced 2times and now we are not able to.
I can check in next version and if not reproduciable,we can close this issue.
(Assignee)

Updated

5 years ago
Assignee: nobody → mbudzynski
(Reporter)

Updated

5 years ago
blocking-b2g: leo? → leo+
(Assignee)

Comment 15

5 years ago
I was not able to reproduce the issue today.

Comment 16

5 years ago
Leo could not reproduced this issue
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.