Height of a parent 'div' with style="display:table" is calculated incorrectly if it contains a child 'div' with style="overflow: [any, but static]" and a large 'table' inside the child

RESOLVED DUPLICATE of bug 883793

Status

()

RESOLVED DUPLICATE of bug 883793
5 years ago
5 years ago

People

(Reporter: vladimir.frizen, Unassigned)

Tracking

21 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.99 MB, application/octet-stream
Details
(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

Create the following page and open it in a browser

<!DOCTYPE html>
<html>
<body>
<div style="display: table; border: 3px solid red">
    <div style="width: 100px; height: 200px; overflow: scroll">
        <table>
            <tr><td>
                <div style="height: 500px;">	
					Bug	in FF, Chrome, Safary, Opera<br/><br/>
					OK in IE8+				
                </div>
            </td></tr>
        </table>
    </div>
	
</div>
<div style="display: table; border: 3px solid green">
    <table>
        <tr><td>
            <div style="width: 100px; height: 200px; overflow: scroll">
                <table>
                    <tr><td>
                        <div style="height: 500px;">
							Correct behavior 
                        </div>
                    </td></tr>
                </table>
            </div>
        </td></tr>
    </table>	
</div>
</body>
</html>

I have attached the page and a video to illustrate the problem.


Actual results:

The red square height is more than the height of the element with scroll bars.


Expected results:

The green square is equal to the internal element with scroll bars

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 883793
(Reporter)

Comment 2

5 years ago
Created attachment 763486 [details]
An HTML file and a video
You need to log in before you can comment on or make changes to this bug.