[SMS] The handset always displays the last screen accessed when selecting message icon from contacts

RESOLVED DUPLICATE of bug 880115

Status

P2
minor
RESOLVED DUPLICATE of bug 880115
5 years ago
5 years ago

People

(Reporter: leo.bugzilla.gaia, Assigned: gduan)

Tracking

unspecified
1.1 QE3 (26jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: [TD-44988])

(Reporter)

Description

5 years ago
1. Title:  The handset always displays the last screen accessed when selecting message icon from contacts.
2. Precondition: One contact on Call Logs and Contact should be saved in contact app
3. Tester's Action: (1) Dial -> Call Logs -> Select a call log
                 (2)Select the message icon > Press Back key on compose screen
                 (3)Go to Call Logs again and repeat the step 1 and 2
                 (4) Check the screen displayed.
                 (5) Access other screens in the message menu (Compose screen,   All messages screen) and repeat steps 1 and 2 again.
               (6) Check the screen displayed.
4. Detailed Symptom (ENG.) : The handset always displays the last screen accessed.
5. Expected: The handset should display the compose message screen with the contact previously set all the times.
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train: Reproduced on v1-train and master
8. Gaia Revision:  20c8fb29caf13e5a4530ba5c7b837a849c79c91b
9. Personal email id: sasikala.paruchuri8@gmail.com
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo+
Whiteboard: [TD-44988]
Target Milestone: --- → 1.1 QE3 (24jun)
Assignee: nobody → gduan
(Reporter)

Comment 1

5 years ago
Hi gduan,

In activity_handler.js 
if (MessageManager.activity.isLocked) {
 return;
}
What is the reason for this isLocked and exactly it will do.
There is one link provided here https://github.com/mozilla-b2g/gaia/issues/5405,unable to open this link to get the information.
Please let me know what this will do ASAP
Thanks,
Leo
Flags: needinfo?(gduan)
Flags: needinfo?(fbsc)
(Reporter)

Updated

5 years ago
Priority: -- → P2
(In reply to Leo from comment #1)
Please refer to https://github.com/mozilla-b2g/gaia/pull/10321#issuecomment-19277591.

Bug 880115 and Bug 878735 both can fix this bug , but they are all under reviewing.
Flags: needinfo?(gduan)
Leo, I think this is a DUP of 880115. Could you take a look? Thanks!
Flags: needinfo?(fbsc) → needinfo?(leo.bugzilla.gaia)
(Reporter)

Comment 4

5 years ago
Hi Borja,
This is the duplicate of the Bug:880115.we observed that the problem is because of the below mentiones if statement
In activity_handler.js 
if (MessageManager.activity.isLocked) {
 return;
}
The duplicate bug may solve this problem.
Thanks,
(In reply to Borja Salguero [:borjasalguero] from comment #3)
> Leo, I think this is a DUP of 880115. Could you take a look? Thanks!
Flags: needinfo?(leo.bugzilla.gaia)
I tested 880115's solution and it does solve this problem , so I mark it as a DUP .
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 880115
You need to log in before you can comment on or make changes to this bug.