Segmentation fault if switching between pref panels quickly

VERIFIED DUPLICATE of bug 86723

Status

SeaMonkey
Preferences
--
major
VERIFIED DUPLICATE of bug 86723
17 years ago
13 years ago

People

(Reporter: Jesse Ruppell, Assigned: Samir Gehani)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
To reproduce:
1. Open Preferences
2. Click on Colors, then before that panel loads, click on Fonts, and before
Fonts panel loads, click on Colors.
3. Mozilla segfaults

Expected:
The panels will continue to load one at a time, in the order I clicked on them.
 Or possibly, the panel for the most recent pref clicked will load if several
have been clicked in rapid sequence.

This will happen with other pref panels as well - the above is an example. 
Sometimes it only takes two clicks to get the seg fault, sometimes a couple more
(maybe my fingers are too slow).
This seems like at least a 'major' bug to me, but I will leave it to the owner
to set the severity.

Comment 1

17 years ago
Actually, feel free to mark a crasher bug major or critical when you file it.  

However, you forgot the Build ID you saw this on.  Can you please post it?

I can't reproduce this on 2001062721/Linux trunk.  There may be a race condition
that I can't hit due to my machine being fairly speedy (P3/800).
Severity: normal → major
Keywords: crash
(Reporter)

Comment 2

17 years ago
Right, sorry: 2001062906, but I see this on builds of 0.9.1 too.  Might even be
older...
(can i have a nap now?)

Race condition seems improbable.  I'm running a P3/800 as well, with 196MB ram.
 I have one instance of Mozilla running (with mail) and SlickEdit.
Question:  When you click on an item in the pref tree, how long does it take for
that panel to open?  For me, most take about one second, while a few take two
seconds (eg. Fonts and Languages).

Comment 3

17 years ago
Hmm.  Your numbers for how long it takes to open the panels agree with what I
see.  Nonetheless, I can't get this to crash.  I'll hunt around.
Keywords: qawanted

Comment 4

17 years ago
Keep an eye on bug 86723; they may be related.

Comment 5

17 years ago
Yup, got a crash, linux 2001062814, talkback filed, TB32338411Q
Exact reproducible steps: go into prefs and close all pref panels, press ok and
go into prefs again. Appearance always shows opened, and navigator is always
selected. Press on the -> from the bottom panel and go your way up, closing the
appearance one (because it is always opened)
Marking NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

17 years ago
Hmm, actually, i am marking this one dupe of bug 86723. It's the same

*** This bug has been marked as a duplicate of 86723 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

17 years ago
May I ask how it was determined that this is a dupe of bug 86723?  The behaviour
that I reported had nothing to do with clicking on the twisties.  Is there
something in the talkback that shows that this is the same bug?

Comment 9

17 years ago
I saw your "steps to reproduce" and it involved clicking on colors, fonts, etc;
those are categories in the prefs panels, other people call them twists, and the
bug i duped this one with had the same problem but had a more exact step to
reproduce, and i believe that the stack trace of the crash would be the same
If you dont believe me, submit your stack trace and the developers will tell you
if it really is a dupe

Updated

17 years ago
Keywords: qawanted
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.