network monitor details can't be copied more than one painful line at a time

RESOLVED DUPLICATE of bug 862020

Status

RESOLVED DUPLICATE of bug 862020
6 years ago
8 months ago

People

(Reporter: jidanni, Unassigned)

Tracking

23 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130614 Firefox/23.0 Iceweasel/23.0a2 (Nightly/Aurora)
Build ID: 20130614004016

Steps to reproduce:

CTRL+SHIFT+Q and then refreshed the page and selected "Headers".
Then hit CTRL+A thinking maybe I could copy all the headers with the mouse.


Actual results:

Found I was only allowed to copy them ONE LINE AT A TIME !!


Expected results:

Don't disable CTRL+A or CTRL+LEFT CLICK to copy more than one line of headers at a time!
(Reporter)

Comment 1

6 years ago
Same goes for Cookies, Parameters, etc.

There is a Response item which allows CTRL+A, but is oddly missing a right click meun.
(Reporter)

Comment 2

6 years ago
Meun->menu.
(Reporter)

Comment 3

6 years ago
One notes that the right click menu for each line indeed already does have a Select All CTRL+A... but this only refers to that particular line.

NO thought was given to people wanting to copy more that one mere line at a time!
(Reporter)

Updated

6 years ago
Summary: network monitor headers can't be copied all at once → network monitor details can't be copied more than one painful line at a time

Comment 4

6 years ago
Maybe bug 859058 and 859059 are related.
Status: UNCONFIRMED → NEW
Component: Untriaged → Developer Tools: Netmonitor
Ever confirmed: true
(In reply to Aleksej [:Aleksej] from comment #4)
> Maybe bug 859058 and 859059 are related.

Yup, but bug 862020 and bug 862019 (or bug 859133) are more relevant in this case.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862020
(In reply to jidanni from comment #3)
> One notes that the right click menu for each line indeed already does have a
> Select All CTRL+A... but this only refers to that particular line.
> 
> NO thought was given to people wanting to copy more that one mere line at a
> time!

We have given thought to this, we just didn't have time to implement it yet. Thank you for filing this bug. It's a duplicate of bug 862020, which will be taken care of as soon as possible.

Updated

8 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.